Hdd not initializing on Mojave

Hi, for some reason if I want to mount a external hdd even on afps or Mac Journaled is really slow to mount and even don’t want sometimes… brand new G drive from Apple, other external Toshiba also, same issue. Using a small usb c to usba dongle on one and using direct usbc to usbc cable from box, same issue.

Any ideas?

Not happening with my external T3 and T5

Launch Disk Utility. Select external drive icon (or mount external drive if necessary by selecting greyed-out external drive icon then choosing File > Mount).

Click ‘First Aid’. See if that command tell you anything, or if it helps.

No errors and it did not help :frowning:

Have you tried another cable?

yes I did, Apple Original Cable, the one in the box, even the one that I use for my SSD T5 that are USBC to USBC … :frowning: I did some reading and it say that HDD is not too good with APFS, however I even tried Mac journaled and not working. If I use exfat it works better but not as good like in my 2015 Mac book pro…