HELP! Constant issue between 2017 iMac 27" and WD External Harddrives

For about the past 4-6 months, I’ve began having difficulties with my external hard drives - both are WD (1 is a 4TB MyBook and other is an 8TB EasyStore, both connected via USB and my 27” 2017 iMac. In short, I first noticed the issue when I would randomly get error messages saying that “Time Machine couldn’t back up to Time Machine.” When I click the details button, it really doesn’t give too much more information, just that “…unable to complete backup. An error occurred while creating the backup folder.” The drive itself still shows up in the finder as mounted and I can even click through my folders and view files. However, when I try to play a video file with an application like VLC, I get the error “The application ‘VLC’ can’t be opened. Error -36” Additionally, when I delete something from the hard drive and then try to empty the trash can, I get the error “operation can’t be completed because an unexpected error occurred (error code -50).”

In other words, the drive shows up as mounted in the finder but is essentially useless, despite the fact that I can still see all my folders/files.

Another complicating factor is the fact that I actually have TWO WD external hard drives connected (other one is an 8TB). This 8TB is partitioned into two portions - one that is cloned backup of my other 4TB HDD (using CarbonCopyCloner), and the other partition is the Time Machine backup. But when I get this error message of “Time Machine backup failed” that seems to be my indicator of the problem, neither drive works. The time machine won’t backup on one drive and I’m unable to play/open files on the other drive (again, despite the fact that I can still see everything through the finder).

In terms of correcting the problem, the ONLY solution is disconnecting the external HDD or restarting the computer (which has “disconnecting” the drive as part of it). But I guess it is helpful to know that it doesn’t seem to require an actual computer restart and only needs the drive disconnected/reconnected. However, when I do try to drag the hard drive icon over the trash to eject it, I can an error saying it is currently in use and would I like to force eject it. I am able to force eject it, the icon goes off the desktop and the drive is ejected.

The problem is that it’s only up and running/functional for about 2-3 days (sometimes more, sometimes less) and then I get that stupid Time Machine backup error. Then restart computer to lazily “fix” the problem instead of posting to this forum and trying to figure out the root cause of this problem! Should also be noted that this problem started on the last version of OSX and continues to plague me now with Mojave.

So any ideas what could be going on or has anybody ever had this happen to them? Is there any utility or activity log or terminal function that I could utilize to get a “play by play” of exactly what’s going on to try and uncover this error whenever it happens?

I’ll be following this thread very closely so if you need more information from me or have any questions, feel free to post and I’ll get back to you ASAP! Thank you in advance!


I get similar problems with a Seagate 8TB external with my 2011 mac mini (no Mojave for me!). However, it is also split into 2 partitions (one for TimeMachine and one just as an external drive). Similar symptoms of time machine failing being the first indicator, although I’ve only had the drive for a few weeks so haven’t really looked into it more.

Same problem here with a WD Elements 3 TB from 2016. :frowning: Just reformated at the last weekend. If i get this error again, i will buy a new harddrive for my backups.

I had this issue with my 2017 iMac and WD external drives. The WD drives were 3 or 4 years old and I finally just replaced them with new WD drives and the problem was solved.

Would test my drive with the “WD Drive Utilities” - version 2 from… 2015. -> “No Updates found” and also the external drive was not found = useless.

I always had issues with WD externals and
my iMacs. Both with my older 27” and my newer 27”5k. They would appear to disconnect for no apparent reason. Haven’t had that problem since I switched to G-Tech externals.

Not sure it’s the same issue, but my 2015 rMBP Mojave laptop is a real pain now with USB drives (WD, Crucial SSD in Sabrent enclosure, etc.) If the drives aren’t recognized when I connect my clamshelled laptop to power, display, and usb hub, I usually have to reboot. Sometimes I can disconnect the usb, cycle power on the hub, then reconnect and the drives will be seen. Usually it takes a reboot. Very annoying. I’ve tried different hubs, from cheap to expensive - doesn’t seem to matter. I can’t recall if this started with Mojave, but I think it predates it a few months. Definitely seems to be macOS related.

Keyboard and mouse connected to the same hub work fine.

If anyone happens to know a command to unload and reload whatever kext might be involved, or have macOS search for drives, I would greatly appreciate your posting it.

i had numerous problems with usb drives on the mac in the last your , most of them were disk problems . higher capacity disks have higher error rate and cause problems with backup , with couple of disks running grc’s spinrite made the disks funcional again . i some cases the disk became useless after couple of monthes .

how to use apinrite .

bare in mind that the same disks usually run better from nas and thus i moved all my backups to the nas .

I posted this same thing on MacRumors and one poster asked if I had any of the WD software installed on my computer, as it seems to be very buggy and known to cause issues. I did in fact have this installed (usually don’t, but had some issues with partitioning the drive early on so I downloaded it). Interesting thought, so I uninstalled the software. We’ll see if that helps at all, I’ll be sure to update you guys! If that doesn’t work, I guess the next step is to try to erase and start from scratch, but these drives are huge and I don’t have an extra 4TB or 8TB sitting around to move the data to temporarily while I erase. We’ll see…

1 Like

HERE IS THE FIX (via Macrumors thread) - DELETE the WD software. It was absolutely the cause! Once I deleted it, I’ve been up and running without issues/restarting/losing connection for the past week. Before this, I would be able to go about 1-2 days most. This is absolutely insane to me that a software could cause this but good to know! Consider this case closed but hopefully others can reference this/keep it in mind. Thanks guys.