Help me figure out my usage for a NAS and my backup strategy?

mac
#23

@OogieM

Well, I’m not totally sure I can troubleshoot your WebDAV connection with the information provided, but here’s some information and thoughts.

As you likely know, you connect to a WebDAV server the same way as you would to an SMB or AFP server. You connect via the proper URL, so as you would connect to your Synology NAS (let’s assume you named it SNAS) for smb via smb://SNAS.local/Share, you would connect via WebDAV to http://SNAS.local/Share. You would replace http with https if you are connected with an encrypted connection.

This is done from the Finder via the Connect to Server… item of the Go menu, or by typing ⌘K in the Finder and entering the server URL as noted.

Note that you would typically include your username (on the NAS) as part of the url, as http://username@SNAS.local/Share, and you might be using the IP address of the SNAS instead of its network name if that’s how you are referring to the NAS. Synology supports mDSN (Bonjour) so you can generally connect to SNAS.local. You can test that by ping’ing the NAS from a Terminal window, which if your husband is a Linux user, he would know how to do if you are uncertain.

Let’s assume that you have enabled WebDAV on the Synology, because you mentioned your husband can connect from his Linux box. Then you too should be able to connect. Note that on the Synology, you can enable services on a per-user basis, so make sure that whatever account you are using for the WebDAV login is enabled for that service. If you and your husband are using different accounts on the Synology, try making the WebDAV connection from your husband’s account on your NAS to see if that is the issue, or check the permissions on the Synology.

Another point is that the Synology by default does NOT use the standard WebDAV ports for the connection. Make sure you are connecting to the correct ports. By default, Synology uses port 5005 for WebDAV and 5006 for WebDAVS, so your full url then would have to become: http://username@SNAS.local:5005/Share or https://usernam@SNAS.local:5006/Share.

Hopefully this gets you on the right track; if not, perhaps post how your husband makes his connection and how you have your Synology set up and maybe I or someone else can help more.

0 Likes

#24

Thanks for the assistance.

Currently I have a username on the server and I can log in for file exchange to several partitions. I see the server in the finder sidebar as a shared disk system and when I select it I can log in and get to any of the partitions I have access to.

When I try to log in as a WebDAV user I try to connect to server and have been using this form of the login: https://192.168.0.208:5006/test1

where test1 is the location I want to put my omnifocus data and my DEVONThink Sync store. I get a window asking for username and password, which I enter in and then get an error “There was a problem conecting to” and the server address.

Then I tried this login https://oogiem@192.168.0.208:5006/test1 with same results (oogiem is my username on the server. I’ve also tried both versions as http without the s and the port 5005. Still no access.

If I select servers from the shared section of a finder window the only servers I see are my own server app running on my mac as oogies-2013-imac and oogies-2013-imac.local

When my husband looks with his tools he sees my server on my mac, the synology as a disk drive with his partitions and the synology as a webdav server.

He’s verified that we both have the same permissions and access.

I can’t get logged in to WebDAV with his username and password either so I suspect the issue is something on my side but I’m baffled as to what to do to figure out what stupid error I am making.

ps we also just tested him logging in from his machine with my username and password and it works so clearly the issue is on my end somehow.

pps I can ping asgard.local and I can ping if I use the ip address so I can clearly see the server (Our server is named asgard) (( which may mean I am unworthy to cross the bifrost :sigh: ))

0 Likes

#25

Any luck with the fixes? Also have you looked at the latest Mac Mini? Might fit your replacement for being used as a Mac server.

0 Likes

#26

We did full reboots of all machines. I still cannot get logged in to the newly created shared folder where I was going to put all my synced items.

However, I can store them in the other folder that is also shared where I keep my picture files and the materials for my historical society project. The sync is working with the DEVONThink SyncStore and my Omnifocus sync document stored there.

No clue why I can’t use the newly created folder, we’ve checked permissions every which way but since it’s working to the other folder we aren’t going to worry too much.

1 Like

#27

Hey any further luck @OogieM?

0 Likes

#28

I’m a bit torn and slightly intrigued about the idea of a Mac Mini as a always on server. I tend to use my current computer somewhat similarly anyhow

0 Likes

#29

I decided that it wasn’t worth the time to figure it out since I got it working in one folder. Part of my attempt to settle for good enough as opposed to perfect so I can actually finish more things. :slight_smile:

1 Like

#30

One is a software license, the other hardware. In your 10% cost estimate, you are leaving out the hardware to run unRAID on.

1 Like

#31

That was my point. Thanks for stating it in other words. :slight_smile:

0 Likes

#32

Oh, sloppy reading on my part.

But to add to the discussion: what’s the cost of managing a DIY appliance? While I deployed several enterprise-level storage solutions, setting them up and managing them involved a lot of work. At home I really prefer a “connect-and-forget” device.

1 Like

#33

Well I think it’s quite telling that from an industry standpoint DIYing is going out of vogue, sure I could roll my own Postgres database server on site, or I can pay amazon to do it for the same, or even a bit less and lose the headache of not focusing on core business.

For me it’s the same thing at home, I want to put the management layer of things on someone else and just get the output more and more.

0 Likes

#34

Depends on what industry and what goals. We run our own Oracle servers and outsourcing the data is completely out of question. The data is critical and belongs to the core business. From a regulatory/legal standpoint, it would also be a PITA. At a former employer, the requirements were too complicated for outsourcing (OCFS2, sync/speed requierements). For vanilla applications, externalizing the stuff is viable.

0 Likes

#35

That’s the appeal of stuff like Synology. Granted UnRaid has forums but it still takes time to post and get support and order compatible parts etc.

0 Likes

#36

I have a Drobo. Right now I’d probably go for a Synology.

2 Likes

#37

I’m still internally debating… Synology came out with a 5 Bay NAS that would be ideal but it’s $700 which seems a bit steep for me. Granted I’d imagine the maintenece of it would be less or time wise then UnRaid possibly. Reguardless if I don’t like it I could always I guess build a cheap UnRaid server and backup to the Synology or resell it.

0 Likes

#38

At that price?

0 Likes

#39

Hey @ChrisUpchurch, curious the context of your comment. I took a look at that thread. It seems that the basic model of the latest Mac Mini would be $799. I think at this point the Synology would help my needs. I looked and Apple doesn’t have any Mac Mini’s for sale as certified refurbished computers. Do you mean my intention of reselling a Synology if I find the UnRaid to be ok for my needs?

0 Likes

#40

Just pointing out that for about the same cost as the Synology you could get a mini and hang a couple of external hard disks off of it.

0 Likes

#41

Great point and if I’d need more storage space I can always purchase larger HD’s or buy/build a NAS

0 Likes

#42

If anyone’s interested in a 2012 quad-core i7 Mac mini with 16Gb RAM and a 1Tb hard drive that’s been gathering dust for a year since I got my iMac hit me up. I was considering using it as a movie server, but maybe I just need to Marie Kondo it out of the house.

1 Like