Help with (HooToo) USB-C Hub

I have a spanking new MacBook Air. I just received a USB-C hub in order to access info, files etc on a little Hootoo drive. The thumb drive fits in but it is either not being recognized or I cannot find it.

On an iPad I find it under Files.

On your top menu select Finder, then Preferences, General. Select Hard disks, External disks, etc.
(Click on the desktop if the top menu isn’t displaying Finder next to the Apple icon at the top left of your display)

Then click Sidebar and check Hard disks, External disks, and whatever else you would like displayed.

Screen Shot 2021-07-15 at 7.07.50 PM

p.s. Don’t be surprised when nothing happens if you touch the screen with your finger. I still do that occasionally :wink:

1 Like

LOL!. You’re funny. The first day I got it I was constantly touching the screen.

I cannot find it under general… it has appearance, web browser but nothing about disks etc.

Check out this video, it should get you to the Preferences. Then check out each tab visible at the top in the first screenshot I posted. You’ll figure it out.

1 Like

Lol. Thanks, Wayne, for the info and your vote of confidence!!!

I was in preferences, general but it’s either not there (under general) or dopey me couldn’t find it.

But you’re right, I’ll catch on!

I know you will :+1:t3:


Well, I found it, Wayne. :grinning: Boxes are checked but I cannot get the UBC thingie to accept the HooToo drive and I cannot get the hub to be recognized by the computer!

Let’s start with some more info. Now that you’ve set your finder preferences your internal drive should be showing on your desktop and sidebar, correct?

If so, does your USB-C hub have a power adapter? Is it plugged in? Am I correct the Hootoo drive is one of these?

If your USB-C hub is connected to your Mac, and is powered up, and the thumb drive is inserted in the hub, it should be showing up on your desktop and/or sidebar. Since it is not,

Open the Disk Utility app. It is located in the Applications/Utilities folder.

Your internal drive will be the first item listed in the side bar. Do you see anything listed under External? If not there may be a problem with your hub and you may need to find someone local for help with that.

In the meantime one option is to use a USB-C to USB adapter with the thumb drive.

1 Like

It just is not recognizing at all. I tried that with Disk Utility. (I recall that app was plenty handy with my old laptops and/or Performa.) Nothing.

I have a USB-C to USB adapter which did not work either. I cannot get the HooToo to fit in the hole. (I had no idea that the HooToo even opened!)

I am returning that to Apple (but it is still here; I didn’t wrap it yet).

Instead I bought a better adapter from Apple for $69.

1 Like

Any solution that gets the job done is a win :+1:


Do you think that may do it, Wayne?

It should. Using the Multiport Adapter removes the hub and/or its power supply as the problem. If it still doesn’t work:

Open the Terminal app (it is located in Applications/Utilities).
Then type “cd /Volumes” (without the " ") and press Enter.
Then type “ls” (without the " ") and press Enter.

You will see the name of your internal drive, probably Macintosh HD, and the name of any other mounted drive. If you see anything in addition to the name of your internal drive your hardware is working correctly and the problem must be a Finder setting, IMO.

(my internal drive is SSD and I have one external drive mounted T7-1000)

1 Like

Thank you ever so much, Wayne!! I should get it on Tuesday, I believe!

I’ve never ever ventured into the Terminal. ;o)

1 Like

I wanted to let you know that I can now access my thumb drive on my computer. The second dongle was perfect.

I SO appreciate all your help!!! Thank you!

1 Like