Help with shortcuts that just stopped working on iOS

Some Siri Shortcuts that used to work on iOS before iOS13 have stopped working.

I hope that maybe someone on here can help me figure what can be done.

Here is a link to a video of a shortcut on iOS that doesn’t work on iOS but does work on iPadOS:

Here is a link to the shortcut on iOS:

And here is a link to the same shortcut on iPadOS:

Hope to hear from some shortcut angels :blush:

looking at the shortcut it has the link to the text on the iPad OS version you linked to, but that link is greyed out in the other one that did not work.

Btw: I think there’s no difference beyween iOS and iPad OS versions of shortcuts?
(At least: mine are 100% the same.)

1 Like

Thanks for your reply and sorry for not responding sooner. I have tried to figure out how to fix it. I recently got a new phone and that didn’t help. Still the same issue.

How do you think I can fix this shortcut on iOS?

Hi Andreas, what exactly is the shortcut supposed to do? add a specific smiley after text in a draft? Can you describe it a bit?

this works for me (changed it a bit)

it adds the timestamp and the emoji to the note specified and opens the note

If you look at this thread, which is where I got the help to create it then you will get the full picture:

Thanks a lot for your help :blush:

I found that many of my shortcuts stopped working because the variables were no longer working. The text in the shortcut made it appear to be intact, but in fact the variable wasn’t referencing the thing it needed to reference. (It was greyed out.)

I deleted and recreated the variable to reference whatever magic variable it needed to reference, and the shortcut started working again.

1 Like

Can you help me figure out exactly what steps or variables need to be recreated in this particular shortcut?

I linked a fixed version of your shortcut in my reply, it should work now
You just need to reference the correct drafts uuid in the shortcut (your own)