Hey Siri Shortcut for Apple TV

Trying to figure this one out.

Current setup.
Room 1 (Bedroom)

  • Samsung TV with an Apple TV
  • HomePod Mini
  • I can say Hey Siri, turn on Apple TV…and both turn on at the same time. (works)

Room 2 (Family Room)

  • Samsung TV with an Apple TV
  • HomePod Mini
  • I can say Hey Siri, turn on Apple TV…the Apple TV turns on but not the TV.

The difference between Room 1 and Room 2 is that in Room 2 I have an HDMI 4K Splitter.

Input 1 - Roku,
Input 2 - Apple TV
Input 3 - 4K Player
Input 4 - Gaming

However, I always leave it on input 2. Is there anyway to just make it work like it does in Room 1? Is there a setting I am missing where my Apple TV doesn’t wake my TV?

Is the second TV older? Newer TVs can be powered on over HDMI, while older TVs cannot.

I have exactly the same issue, I have a new Samsung QLED in my living room that powers on fine and an old Samsung in a second room that doesn’t support TV power on with HDMI.

Do the TV and switcher in room 2 both support HDMI-CEC?

If so, is the feature enabled everywhere (ATV, switcher, TV)?

One test would be to directly connect the ATV to the TV. If this works, the issue is with the switcher. If it doesn’t, either CEC is disabled (on ATV and/or on the TV) or the TV is old enough that it doesn’t support it.

1 Like

Oddly enough the Samsung TV in Room 1 is about 11 years old and is able to turn on with Siri and ATV.

The second TV is my biggest regret. It is also a Samsung, it’s only 3 years old. But Samsung changed some design instead of having the HDMI in the TV they have some hub called Samsung One, I think? I will check today regarding the receiver.

This is the one I have Rocketfish

According to the Manual, it looks like the switch supports HDMI-CEC but it can be disabled. Check the instructions for turning auto switch on/off.

A test to verify at least the ATV and switch are set up correctly would be to manually move the switch to another input then turn on the ATV. If working, the switch should move to the ATV input.

The ATV setting is Settings > Remotes and Devices > Control TVs and Receivers

BTW, it looks like Samsung may refer to HDMI-CEC as “Anynet+”.

The Samsung seems to be enabled for HDMI-CEC. I am still trying to get the Switch to function properly with the auto-switch setting. However, the ATV setting for Control TVs and Receivers is greyed out. I tried cycling the devices, but it is still greyed out