Homekit and "No Response" Revisited

Some time ago I started a thread trying to get some help with remote access to my HomeKit accessories. At the time I thought the problem was solved, but alas it has reared its head again and I am stumped as to what to do. My Home app works great while I am in range of my home network. However, once I get outside my home network (cellular or wifi) all accessories on my iPhone 13 Pro Max and my 16" MacBook Pro M1 Pro show as “not responding” implying an issue with the hubs. I currently have 3 HomePod Minis and 2 Apple TVs (including one just acquired HD 4K) which all seem to be talking to the Home app just fine so am not clear what is breaking between my accessories, hubs, and devices. The really odd thing is that my 2015 iPad Pro and my wife’s iPhone 12 are not have this issue and make remote connection to all my accesssories just fine (my wife chides me that her “older” iPhone needs to lend my latest and greatest iPhone a hand). I have tried all the standard stuff i.e. rebooting routers, hubs, etc. without luck. Is there something about this new hardware. Full disclosure I am running beta software, which I thought was the problem, but so is my iPad which is workiing fine. Anything I might be missing?



Also neglected to mention that I am using an Eero 6 Pro mesh system.

Do you have private relay or a VPN or similar enabled on your devices? That could definitely break things.

Nope. Turning off private relay was one of the first things I did when this all first started. Also, no VPNs running. Another thing I have noticed today since I spent a lot of time playing with this is that the “No Response” does blink on/off periodically (it will briefly connect to my accessories). Had not noticed this before but was staring at this a lot today.

Just to be sure, did you also Flightmode/Reboot your iPhone?

Yeah, done that. I think all my devices now refer to me as “Mr. Reboot.”

I have this gut feeling that the HomePod Minis are the source of the issue as well. What is odd is that some of our devices experience the issues and others don’t. Even so i will give what you suggest a go and see what happens!

Pulling my hair out with the Homepod mini as well. I have to reboot it multiple times per day and the Home app doesn’t even tell me what to do or how to fix those problems. I always end up just asking Siri on my phone to run things.

Sometimes it can turn on my AppleTV, most of the time it tells me it doesnt have the ability to do so.

“Matter” - Yet another generic product name that is not unique or easy to search. I heard an ad the other day for something called “Electric”. Who would name their product that? :slightly_smiling_face:

It is like “Ulysses”.
A nice app, with a really bad name, if you try to find any general information about it, or to solve a problem!

1 Like


The problem persists. After extensive testing and additional reboots it has become clear that this problem only appears to exist on my iPhone. My iPad and 16" MacBook Pro M1 Pro can remotely control my homekit accessories just fine. The active Hub seems to be the ATV in my master bedroom rather than the new ATV in my family room (as we all know no way to actually choose which hub you would like to be the main hub). On my iPhone when I look at “Routers & Extenders” it indicates that there is no response from any of my three Eero Pro 6’s that are part of my mesh. For each of them it says that the router name is not the same as my wifi network name. But again, I do not get this error on either my Macbook Pro or my iPad so I suspect this is not the real issue. I am beginning to think that this might actually be a problem with my iPhone.

IoT device troubleshooting is so infuriating, much due to the total lack of feedback of any kind. When looking for solutions, an error message could be really helpful. Esp. if it says more than “Device unreachable - please try again later” in the companion app.

I have finally managed to get all my devices up and running, but dang, so many bad interfaces and totally opaque installation procedures… The standard for shipping software seems to be “if it barely works on my developer machine, it’s done!”.

Issue Resolved…Maybe!!

Has anyone ever solved a problem and not known for certain exactly which thing you did actually fixed the issue? I am a scientist and generally attach things in a very linear manner (i.e. changing one thing at a time) so that I can truly learn why something broke. This works until you decide to call Apple and see if they might have a solution. Well, that is what I did yesterday. To be honest, I made it through two levels of support, neither of which had any suggestions that I had not already tried or were on my list of things to do next. The people I worked with were kind and not in a rush, but the difficult thing was that when we would try one thing that was taking some time (more on that in a bit) they always wanted to move to something else while waiting. Thus, if the problem resolved I would never know exactly which thing fixed it.

When all was said and done my gut feeling is, that as several of you have suggested, the core issue was with the setup of my master bedroom HomePod minis. After doing several other things (including deleting all my VPN apps which in my view was a waste of time) I factory reset my HomePod minis and then added them back into my Home app. When re-adding the minis I also re-paired them. What happened is that during the re-add they got stuck “configuring.” At this point the Apple “tech” had me sign out of iCloud then sign back in. When I did this the Home app became stuck “Adding Accessories and Scenes.” At this point I suggested to the Apple person that I re-start my phone. I immediate did so without thinking as that abruptly ended my call with Apple. Frankly, probably the best thing for me. Realizing I had done this I decided to take a more linear approach.

  1. After the phone re-boot I again tried to re-link the Home app with iCloud and again got stuck “Adding Accessories and Scenes” (I let this run an hour before I decided it was not really loading anything).

  2. Deleted and re-installed the Home app. After re-linking to iCloud it again got stuck “Adding Accessories and Scenes.”

  3. After a quick Google search found a Reddit post that suggested this problem could be overcome by going to iCloud in settings and turning off Home then toggling off and on keychain. Did that. Then, starting the Home app and linking to iCloud from within Home (rather than in settings). Worked like a charm. All my homekit accessories, scenes, automations reloaded nearly instantaneously.

  4. For the second time I removed the HomePod minis from the Home app, factory reset them again, then re-added them. This time I did not pair them. Decided I would wait until they were both successfully re-added to Home. After re-adding them they once again seemed stuck “configuring.”

  5. After another Google search I found an article (forget who wrote it) that suggested if the minis got stuck configuring to just exercise patience as sometimes this will resolve itself after several hours. So, just let them go and went to bed.

  6. When I got up this morning all my morning automations had correctly run, and best of all the HomePod Minis were fully added and functional. I paired them without issue. Best of all, when I went to work this morning my location-based automations (which have not worked in weeks due to the “Not Responding” error that started all this) fired off perfectly. I have been at my office for a few hours now and everything is connected and working as it should (if you made it to the end of this post thanks for putting up with my long windedness).

Thanks you do everyone who made suggestions in this thread. I will check back in in a few days to let you know if there is still Homekit joy in my life.