HomeKit Garage Door Opener won't connect

Hello all, for the past year I had bought the Meross HomeKit MSG200HK garage door opener and it worked flawlessly. My kids could use their phones to open the garage and I could use Siri. We had a short power outage and since then it’s not working.

  1. I can reset the device and connect it to the Meross app.
  2. I can reset the device and connect it to my Home, but it lists both garage doors as “No Response.”
  3. I can connect the device to a new home and get it to work fine, but this home isn’t connected to my HomeKit hub (Apple TV I presume since I don’t have HomePods). When I got this New Home to connect to the HomeKit hub (I’m not sure how I did it), it went back to “No Response.”

I’ve been spending the past 2-3 months with the Meross rep (via email) trying to trouble shoot this. Bless her patient heart. I’m guessing this has something to do with the HomeKit hub. In Apple TV (we have 3), I have no idea which one is acting as the hub. Or is it all of them. How can I reset everything to start working again?

Thanks for any insights!!

Have you tried unplugging your hubs one at a time and then plugging them back in?

Ugh. Power outages have wreaked havoc on my smart home stuff, too. Have you tried restarting all of your Apple TVs?

I have restarted them but not one at a time. Does that make a difference? I’m willing to try anything at this point.

We have some Google Nest thermostats (doesn’t go in HomeKit unfortunately) and it seems to “just work.” It just happens to only work with the Google Home app. (I know I can get a Starling Hub but I need a free ethernet port which I don’t have right now.)

1 Like

Have you tried RESETTING your ATV? You may have to through reinstalling apps and settings but this brings it back to factory settings. Check it out on Apple support page. Just a thought.

Resetting all of them to factory settings? This will not make me popular at home.

Are all HomeKit connections this fragile?

I know this isn’t your main issue, but you can get simple Ethernet switches with 4 ports for $10. The lack of Ethernet ports shouldn’t be a real barrier.

(Ethernet switches, in an oversimplification, are like power strips for Ethernet - turns one Ethernet port into 4, 8, or 16 more with no loss in signal or capability.)


First check if the garage door opener is still connected to the network.
You can run an IP Scanner application available from the App strore. It’s unlikely that the device is showing with a recognizable name. Take a picture of the label on the garage door opener with the MAC access clearly visible. This will help you identify the device.

You can also log into your router (or modem/router box from your ISP) and look for the list of attached devices.

It’s likely that it’s not connected to the network or somehow ended up in a different IP address range. If so I would reset it to factory settings and do a new setup.

It’s also possible that it cannot connect to your WiFi because it can’t keep the SSID on 2.4 and 5Ghz apart. I have fought that battle with some Belkin devices and an early version of the Ring doorbel.

If it’s the problem that it doesn’t want to connect to your WiFi network. Go into your router’s WiFi settings and find the option to “smart” manage or some other form of setting that combines the 2.4 and 5Ghz into one SSID. Rename the 5Ghz by adding 5 to its WiFi name (SSID).
Next connect the garage door opener and complete the network setup.
Once completed you can change the WiFi settings back to how it was before. (that’s why I recommend to only change the 5Ghz SSID) so things are back to regular insanity :wink:

I had something similar with a MSG100. Updating the firmware to 4.2.12, resetting, readding and restarting the wireless router did the trick.

1 Like

I tried this with no success.

I’ll try this today.

Are there certain best practices when using HomeKit? I read somewhere all the devices be on a different wi-if network than the rest of us use.

Yep, this has happened with one of my Meross openers, an outdoor plug, and light switch. This is what I did and it makes absolutely zero sense.

FWIW the devices have been really solid but my GOD when it craps out it really craps out.

Unplug the opener and let it sit.

Go to your router and delete the opener. I did this through the Orbi app.

Go to the Meross app and delete the opener. Do this on every device with the Meross app installed.

Log out of the app then delete it. Again for every device with the app.

Open Home app on iOS not on AppleTV and delete the opener.

Select 1 of the AppleTVs are the home hub not all of them.

Restart the AppleTVs to make sure only one shows as the HomeHub.

Ok……go back to the opener and plug back in.

Hold the Reset button until flashes like looking for network. I did the reset 5 more times then unplugged it. Let it sit for 10 mins (again, it’s what I did).

Download a fresh copy of the Meross app on 1 iOS device and login.

Plug in the opener and let it find the network.

Add device to the Meross app, DO NOT rename it, and leave it in the default room.

Check for updates before adding back in to Home.

Try controlling the opener through the app.

If it works kick it over to Home.

If it doesn’t, repeat steps above until you are ready to drive over it until you feel better.

1 Like

Thanks, @adamashlock. I’ll try all these today. How do I select 1 of the apple TV’s as the home hub? Is this on the AppleTV itself? (There I can only see the AirPlay and HomeKit option in settings and there’s not much there) or on the phone? (I see I have the ability to edit a home and can see an AppleTV listed but cannot do anything with it).

I may have reached this step already.

Yup, experienced the feeling :joy::joy::joy:.

Select HomeHub on the AppleTV. I’m not in front of one at the moment.

Are you running a guest network? I’ve had power outages and had some devices hook up to the guest network when the power comes back on. All I had todo was switch them back to the primwry network.

I do have two networks, but everything is connected to only one of them. How would I know to which wifi it’s connected?

I tried all of that with no success. I can get the garage to open if it is connected to the Meross app or the Home app. Once I add the Home to the HomeKit hub AppleTV, that’s when the Meross becomes unresponsive.

This is becoming quite frustrating.

EDIT: I think it may have something to do with one of the AppleTV’s needs to be hooked up to WiFi and not Ethernet. This is odd because all our AppleTV’s are connected to Ethernet.

1 Like

Interesting. I would think it should work being on the same network. So when you enable Wi-Fi does the opener work?

It works as long as my Home isn’t connected to a HomeKit hub. Once I make that connection the garage door opener becomes unresponsive.