HomePod doesn’t connect to iPad Pro

ios
homepod
ipad-pro

#1

I recently set up my HomePod from scratch as I was having some issues with Siri not firing up on it.

That issue was solved. But now the HomePod won’t connect with iPad Pro.

The Home.app on the iPad Pro says that the HomePod is on a different network.

I have a “normal” network and a a 5G GHz network which I never actively connect to.

Can anyone help?


#2

I encountered that problem too. The HomePod must be on the same network as the running device. Like you I had a 2.4 and a 5 network. The trick was to tell the iPad to not automatically log in to one of them.


#3

Disable the network you don’t use in the router configuration, then try. Usually, modern devices automatically try to connect to 5Ghz first (it’s not the same thing as 5G!) because a lot of apps need the extra bandwidth


#4

Okay I will try to disable 5G. I have never used the 5G. Why is it there? What is it good for? Any disadvantages to disabling it?


#5

Hi,

It usually means 5ghz, and isn’t related to 5G (which is a mobile phone protocol).

5ghz is far superior to 2.4, but some older devices don’t support it.

You’d be better disabling the 2.4ghz and see if it works (just check older devices work with it too).


#6

I don’t know why I typed 5G :neutral_face:

Thanks! I will talk with my isp and Apple about it and see what they say


#7

Or getting a router/wifi AP that can broadcast a single network on both the 2.4ghz and 5ghz bands.


#8

Yeah that would be better. It’s a pain in the ass that connecting to the HomePod to check what song is playing on either iPhone or iPad is so flaky. I see this really often even though something is playing:


#9

Something you might try is disconnecting from the network you don’t want the HomePod to use and Forget the network as well. Set up the HomePod and the network settings will be transferred to it from your phone. Since the HomePod doesn’t have the network password, it might use the network you prefer for it to use.

Untested, but sounds plausible.


#10

JohnAtl has the right idea. Have the HomePod sign on to one of the two networks (2.4 and 5Ghz) and then make sure the iPad signs on to it as well. If you choose the 2.4Ghz network, then you can tell the iPad to forget the 5Ghz network in Settings app. In my case I didn’t have to do that. They both are on the 2.4Ghz network (see below).

Don’t eliminate the 5ghz network from the router, it is useful. The general rule is that 5Ghz is faster than 2.4 but 2.4 has longer reach. Of course, mileage varies depending on your house, interference from appliances, the number of connecting devices and competition from neighboring networks.

WiFi networking is a big mess. From what I hear, mesh networks are a big improvement over traditional networks. Unlike with some people, my devices almost always sign on to the 2.4Ghz network even though the AirPort router is is set to choose the best network and we (the devices and the router) are all in the same room only a few feet apart. I have the loneliest 5Ghz network!


#11

Question: Why would you configure a separate 5ghz network?
Most devices are perfectly capable of switching to the best signal strength when both 2,4 and 5 ghz are the same SSID.


#12

Many APs are set up to do it that way (and often aren’t even able to broadcast the same SSID on both 2.4 and 5ghz).