How do I select the url bar with a keyboard shortcut?

On Big Sur and every previous version of macOS, I used command-L to select the address bar in Safari. I actually do this quite frequently and on Monterey, it doesn’t work. This is frustrating me way more than it probably should. Does it work for other people? Is there any work-around?

⌘-L works for me in Safari on an Intel MBP running 12.0.1. It switched to the URL bar with the entire URL selected ready for me to hit ⌘-C or type over it.

FYI, I run Safari with the Separate tab view but did switch to Compact to check and it worked there as well.

Perhaps you have a conflicting action somewhere. I occasionally have issues with, I think, Karabiner Elements preventing my access to Alfred (via ⌘-space) until I press the right ⌘ key. There is a notification on the screen for this but it some takes me a while to notice it, especially on the 27” monitor.

It works for me both manually pressing the keys and also using a Keyboard Maestro macro that does the same thing to grab a Markdown formatted URL. I have a M1 MacBook Air running Monterey with compact mode turned on.

Try downloading ShortcutDetective and see what is interfering with ⌘L when using Safari. I bet another app or extension has installed a shortcut that gets in the way of it.

ShortcutDetective might not solve the issue, but it’s the easiest way to check, and it’s free.

1 Like

Actually CMD-L (macOS) and CTRL-L (Windows) are universal shortcuts that work with any browser.

Ok, I’m glad to hear that it seems to work for everybody else. I tried running shortcut detective and didn’t find anything. Also, I tried pressing the “Open Location” menu directly and that did not work either. Any other ideas?

I’m curious - do you see ⌘L next to Open Location… in the menu?

Yes I do see that, but when I click on it, it doesn’t do anything.

Is Open Location… disabled (greyed out) like Delete Tab Group in the image above?

Nope. It’s not greyed out.

Go to Preferences, then the Extensions tab and turn off all extensions.


Next step is the usual first step, which is to reboot.

No, neither of these worked. :frowning:

Another thing to try? “This is a bug with new tab/window behavior. Go into Safari->Prefs->General and change both new windows and new tabs to open as an empty page. Then restart the browser. Should allow CMD+L again.” Cmd + L shortcut on Safari does not work anymore : MacOSBeta

Update: I found a solution! I had to turn off screen time content and privacy restrictions. It turns out I had this turned on (with nothing blocked) and after turning it off, CMD-L works. No idea why, but I’m glad to have a fix.


Wow! Great detective work! I’m not sure that I would have figured that one out.

How odd, too.

1 Like