How do I stop compressed files from opening a new Finder window?

Google failed me here. Might be a bug in Catalina? Every time I create a compressed file, a new finder window opens, regardless of the settings in the Archive Utility preferences (see screen shot). Any of you power users have a workaround?

I have the same Archive Utility settings as you, and do not get new windows when opening archives.

Just on the off chance, try looking at General settings in Finder. Here is what I have:

@quorm Thanks for the reply! Though my issue is not with opening archives, but rather with creating them. Good idea about the Finder settings…and I have the same settings as you there.

I did find something interesting: Finder only opens a new window when I create a compressed file from a nested/expanded folder view, like this.

If I drill into the “Test” folder (by double-click) and then compress “Test 2,” no extra Finder window opens. This is the case whether the checkbox in Archive Utility preferences is checked or unchecked.

However, if I run this same experiment for creating archives, the checkbox for that option (“Reveal expanded item(s) in Finder”) actually makes a difference. I can create them in any folder view without a new window opening when the box is unchecked.

I’m having the same issue in Big Sur OS 11.0.1. But for me it only happens when my finder window is in Column view, not list view or icon view. It’s super annoying, especially when I have to compress multiple files – I get multiple finder windows opening for absolutely no reason.