How to change app to “Open in” in Files on iPadOS?

It used to say PDF Expert up in the corner when I opened a PDF in Files. But then I think I may have opened a PDF in Google Chrome at some point, by mistake, and now it says Google Chrome, which I have no use for, I need to see PDF Expert.

Does anyone know how to change that?

Oh I would love to know the answer to this! I follow a prolific iPhone wallpaper designer on Twitter (@ar72014) and when I download a wallpaper from their Google Drive folder, the default application is iMovie!

1 Like

Sounds relevant haha. I don’t think there is a solution yet. As a new feature, I think it’s use cases, but maybe someone on here knows for real

I had started a similar thread:

I’m glad I’m not the only one with this issue. I’d love to have this resolved. If anyone finds a solution, please post it here!

1 Like

Isn’t there a website to submit suggestions or bugs directly to Apple, without going through their support?

I’m not sure about the website but I have several relatively high engineering contacts at Apple. I’m careful not to bother them with issues unless they are major ones. This is a frustrating issue but not one “big” enough for me to email my engineering contacts.

That said, I will certainly post the issue on a website if there is one. If there is, I’m sure someone on this forum will know.


You can either use the feedback assistant on iOS/iPadOS/macOS, or use the website:

if you are not running a beta version of the iOS based operating systems you can use this shortcut to start the feedback assistant app:

1 Like

Wow! Did you make that shortcut?? It’s basically an app of the website right. Amazing. And unbelievable that Apple hasn’t made app for this themselves.

So it’s proper to give feedback on anything in there and requests of Apple apps and software, even when not on beta right?

That’s what I alwys do, and they will reply most of the time as well, so think it’s fine.

and the shortcut idea I got from @RosemaryOrchard

Awesome. But it’s not Apple support minded right? Like if I have an issue with my iPhone crashing, then I contact Apple support through Twitter dms usually - another wery well known secret by the way.

This app is more like feature requests one way ideas for improvement

Unless I am missing the point, this isn’t complicated on my iPad. To change the app that opens the file type, just open the file in files (preview) and go to share, or long press the file to get the share menu. When there, select the app you want to open it with and it overwrites the previous selected opening app. That’s how it works on mine. The process of opening the app with another type then overwrites the previous.

@cheekyjeremy thanks for the suggestion but unfortunately that does not work on my iPad running the latest iOS. I have the default set to PDF Expert on my Mac and I went through the process you suggested for the iPad but the iPad does not change the default open app., in my case it is still defaulting to Bookends.

What happens if you delete the app that your iOS now uses as the default. If the app listed is no longer there, will it not default back to the previous app that it used to use ?.

  1. Delete Bookends app
  2. Reboot iPad
  3. Go to files, try to open the file type in question. If the bookends app no longer exists, surely it will open the file type on either the previous (PDF Expert or Preview etc). Then, once it updates that, maybe then you can reinstall bookends etc if you still need it.

Would that work ?

@cheekyjeremy i’ll give that a try but I do need that app. I’ll give it a try and then reinstall the app to see if I run into the problem the second time. Thanks for the suggestion. :slight_smile:

@cheekyjeremy That seems to have done the trick! I will have to be careful not to open a PDF into Bookends as it seems there may be a bug in iOS 14 that keeps “Open In“ stuck in that app rather than a default app or the last app used to open a file. Thanks a million!

1 Like

Can the original poster mark this as solved as it will help future people find the solution.

1 Like

That would be @andreasl

1 Like

a lot of people have been reporting issues with “open in” and share-sheet options, seems iOS 14 has some bugs in that area

1 Like