How to run Windows 11 in Parallels Desktop on an Intel Mac?

Although I have been able to run Windows 11 beta versions (as a Windows Insider) in Parallels Desktop on my Intel Mac so far, I now can’t perform a clean install with the released ISO. The installer complains that my PC does not meet the minimum requirements, without mentioning which requirement is not met…

The Parallels KB on Windows 11 says I should upgrade to 17.0.1, but I already run version 17.0.1 (51482).

How to get Windows 11 (final) to work in Parallels Desktop on an Intel Mac?

1 Like

Same happening here.

I also tried today to install it on an Intel machine and got the same error.

Even in virtual machines now, your computer must support TPM 2.0 and all of that other stuff.

I know for a fact that there isn’t a single Mac out there that even supports TPM, so we might be in a lot of trouble…

Well, most newer Macs have the TPM 2.0 hardware (it comes built in to Intel chipsets) but Apple has never updated the firmware to make use of it.

1 Like

Ah, yes. You’re right. That’s what I meant. :slight_smile:

I’m not sure if Apple will budge though. Intel Macs are out of the picture now.

I really doubt Apple will implement firmware support the TPM at this point. Microsoft might provide a workaround for the TPM 2.0 requirement, though they seem to be holding fast in the face of pressure from lots of folks with older Windows PCs that don’t support it.

It’s actually rather simple! :smiley:

We need to manually add a TPM to the configuration before starting the installation:


I’d clicked every advanced option but didn’t think to try and add it!
Thanks for the heads up.
Can’t believe it’s not mentioned in the KB for installing windows 11.

Yeah, I highly doubt that Microsoft will attempt to work around Apple’s restrictions. Apple Silicon Macs are the future.