How to select iMac's external and internal speakers

#1

In Sound prefs (and the sound icon in the top menu bar), “Internal Speakers” changes to “Headphones” when I plug my speakers into the output jack.

Is there a way to have both “Internal Speakers” and “Headphones” as choices, so I could switch between them from the sound icon in the top menu bar?

0 Likes

#2

Option-key and a left click on the sound icon should help.

1 Like

#3

All the option-left click does is add input devices to the list. The same output choices remain:
Headphones
Logitech USB Headset
Multi-output device
Soundflower (2ch)
Soundflower (64ch)

But no choice for Internal Speakers is offered, unless I unplug my external speakers from the 1/8" jack in back of the Mac.

0 Likes

#4

Does you internal speakers show up in the iMac-settings/Sound? Maybe the Soundflower-driver “generate” the problem?

0 Likes