How to stop Google automatically adding "google meet" invites to your calendar


Twice today I’ve been waiting on zoom while my friends were waiting on “google meet”, even though I hadn’t added a google meet invite.

It turns out that Google has automatically started adding “google meet” invitation codes and links into google calendar / gmail invites.

It’s taken me 20 minutes to figure out how to turn this off, but it’s quite easy:

  1. Go to:
  2. Scroll down to the “Event settings” section
  3. Deselect the option, at the bottom of that section: “Automatically add Google Meet video conferences to events that I create”

Hope that helps.


Thanks for this; I’ve had this problem and it has been driving me crazy!