I am losing my mind... why is my scanner failing?

This has been mentioned before, but I thought I’d see if there were any fresh ideas out there.

I have an Epson V600 scanner which is fairly new (to me). I can use it to scan documents all day and it works just great. For that, I use Image Capture.

However, when I want to scan slides and negatives, this problem rears its head. The scanner will work for some period of time before this error appears. It can sometimes appear on the very first attempt to preview, or sometimes after many frames of full resolution scans.

At this point the scanner just sort of “pauses”. I think it’s waiting for the computer to tell it what to do next, but the computer (or rather software on it) has “lost contact” and will never tell it what to do next.

From multiple sessions of Googling, the “answers” that have worked for other people have been:

  • Plug it directly into the computer using the cable provided with the scanner (see note below).
  • Reposition (or in some cases modify) the film holder.
  • Reload the driver.
  • Use different software.
  • Use a (cheap) USB hub.

Note: This is Epson’s stated fix. I can’t, because the supplied cable is USB-A so something has to come between it and my Thunderbolt 3 MacBook Pro.

The last point was a new one on me, and I have seen it solve a problem with a WD MyPassport Wireless Pro that would not switch to “USB drive” mode when plugged directly into the laptop. It did not work for the scanner.

I had a similar problem years ago with an Intel Mac and on that occasion I installed an “Epson event manager” which supposedly helped with the messaging between the scanner and computer.

I have tried uninstalling and reinstalling ALL Epson software, and VueScan (which uses Epson’s driver) and I have tried lots of different cables into lots of ports (on the MacBook Pro, on the TB-connected Studio display, on my OWC USB-C dock, and with a StarTech USB-C travel hub).

In some configurations I have managed to get a decent number of frames scanned before it gives up, but it always gives up. At one point, scanning my Grandfather’s slides, I worked out I could quickly quit the Epson Scan software, turn the scanner off and on, then restart Epson scan and hit the go button again (after deselecting the frames I already had) and it would flawlessly scan the frame it crapped out on before.

At this point, my thinking is the issue lies in the data rate over USB and how the M1 affects this. I think this because:
a) I never had this problem persistently with Intel, and
b) Although some people say it “only happens with transparencies” I think the problem is more likely that transparencies are scanned in thousands of dpi where documents are only scanned in hundreds of dpi. I.e. I will never scan a document at more than 600 dpi, but the minimum dpi I will use for transparencies is 2400.

I thought about pressing an old 2009 iMac into service with Linux on it, but discovered (via a Parallels trial) that my scanner is not supported in VueScan’s Linux version. :roll_eyes: My next thought is to get it on an old Mac OS X and get an older VueScan running on it (or even Epson Scan 2 if it will run) and just not have it connected to the internet (or even my network).

Does anyone else have any experience of dodgy USB on M1 Macs and have any other suggestions than an endless combination of cables, ports, and re-installs?

Oh, and I have an older Epson V370 Photo which has exactly the same problems.

This won’t solve your problem, but you could confirm this hypothesis by scanning some transparencies at a lower dpi. If the problem persists it may indicate a new avenue for problem solving.

For what it is worth, I use an Epson Perfection 3200 with Vuescan with my Mac Studio, and have not had any issues. Although I’ve not scanned any transparencies (I have done high dpi scans, but I’m not sure if I’ve done so since I got the Studio). I’d give it a go but am away visiting family. If not sorted by the time I get home I’ll try some high dpi scans and let you know what I find.

Thanks, that’s a good idea.

I do have a 2009 iMac up and running now on El Capitan (with all the fun that brings from being too old). I will be doing testing on that soon, but will also try low-res scans on the M1.

As a comparison point for your attempt, should you do it, I scanned yesterday (on the M1) at 3200 dpi and got a nearly instant failure.

I assume that you already use the latest versions of Epson Scan2 and VueScan, right!?

Yes, and there’s also a quite new version of the Epson driver which I installed this time around. But these problems have been going on ever since I got the M1 in late 2020.

I just found a german article about similar problems with an Epson V600, that could be solved with the latest update from early Dec. (if I remember right).
If you are using parallels, have you tried it with macOS12 as a VM?

I found, as mentioned above, that the ICA driver version had incremented since last I reinstalled, but I haven’t tried installing the Epson Scan 2 software again. I’ll give that a go. They don’t make it easy to check versions!

Frankly, I’m not hopeful, considering this has been a problem for 2 years and I last completely uninstalled, rebooted, and reinstalled all of the Epson software a few months ago. At least I have plenty of time off work at the moment.

Edit: I found the version number. It’s the same one as I have installed already,

The weird thing is I can find posts that say any one of the fixes “worked” for someone to completely solve their problem. But I can also find other people saying it didn’t solve theirs.

When I had the problem years ago on the Intel Mac, I got an email from an Epson tech saying that there was something amiss with the communications and to install the Event Manager software which did fix that issue. That’s why I’m convinced, at this stage, that it’s the same problem but due to the M1 USB architecture somehow.

I also have the experience within the last couple of years, that there is a more “unique” approach to whether a solution is working for a specific system, or not.
I have, for example, a couple of very special problems with my Apple Mail, since I deleted the MailSuite. Those problems remain on the system now for several years, and while I made several “clean” reinstallation of the complete system.
Also, if I search for the problems on the Internet, it seems as if I would be the only owner of a system with those unique problems.

Based on what has been shared, this may not help, but we had an issue with a scanner staying connected as well. It would see it, connect, but never scan. The scanners were a bit older as well. The final solution was to to change the IPv6 setting on our router. We changed it to pass through rather than turning everything on. From what we read, it had something to do with the older scanner not working well with IPv6. All has worked well since the change. Here is the MacWorld article that talks a little about it: https://www.macworld.com/article/234654/scanner-wont-work-image-capture-disable-a-network-setting.html

Well that was a new one, thanks! However, I can now add it to my list of things which don’t work. :roll_eyes:

I turned off my printer’s wifi completely, and checked my router already had IPv6 disabled. After a reboot, it still failed quickly.

Time to try the low-dpi scans now…

1 Like

…and that’s a fail, too.

Epson Scan 2 didn’t offer explicit control over the preview resolution, so I went to VueScan and tried a 150 dpi preview. That almost worked but it ended up crashing while doing a second pass for reasons I cannot fathom. A second attempt failed to even move the scan head before hanging on the Calibrate… step, which is the standard MO for VueScan with this problem.

So it seems it is something to do with transparencies. Which would tend to suggest the issue with the film holder. However, I am not inclined to believe that one considering my V370 is a different design, also has this problem (it was the scanner I was using when I switched to M1), and worked fine for a long time prior to M1.

And my first run using the old iMac with El Capitan… 100% success. It previewed at 400 dpi and scanned at 3200 dpi with no complaints.

So something in my newer setup is the issue. Whether that’s the M1-ness or something else I don’t know. I really don’t like the idea of a nuke and pave, but it’s starting to seem like the next step. :roll_eyes:

1 Like

What about a new User first, or the actual macOS as a VM, to see if it makes any difference, before you start a nuke and pave…

1 Like

Good idea. I have a Parallels trial at the moment — how I found out my scanner is not supported in Linux for VueScan — so can spin one up easily.

I really appreciate the flow of ideas.

1 Like

So… Parallels on Apple Silicon is still (after two years!) somewhat limited. An important limitation for this exercise is that you cannot assign USB devices to the VM!

It’s a Christmas Miracle! :star2:

I was not hopeful on the new user account because all of the required software was already present on the account. Surely the problem would also be present?

But no! I was able to preview then scan 5 frames — the same 5 I have been testing throughout — and do it twice. Once to 3200 dpi JPEGs and once to 4800 dpi TIFFs.

So… some piece of software (that I have had installed for a long time) is interfering.


To prove the solution, today I scanned 98 of my grandfather’s slides, at 3200 dpi, with an additional infrared pass for dust removal. Not a single stoppage.


Did you ever sort out the underlying issue?