I hate Printing! (It never works correctly)

This is an ongoing problem every time I add anything new to my mix. This time it’s trying to get my new MacAir Catalina machine printing to the HP printer that is connected to my iMac.

Printer is attached to my iMac. It’s set to share. Both iMac and new MacAir are on the same WIFI network.

I can see the printer from the MacAir. I can try to print something from the MacAir, get the print dialog, and it appears that it all works. However, on my iMac the print queue never gets a document to print and the MacAir shows the item as “printer in use”. I can print successfully from the iMac. Both machines have the same version of the HP Printer drivers.

I’m clearly missing something simple but I can’t see it.

I just dealt with this for a client. HP printer was super janky with Catalina over Wi-Fi. For them, I did this:

  • Turned off Wi-Fi on the printer and connected it to the network via Ethernet.
  • Remove the printer from System Preferences
  • Install the most recent HP software on the Mac.
  • Set the printer back up as new, using the correct driver.

Please note his forth point: using the correct driver. It often defaults to AirPrint rather then the dedicated software…


um several issues

The printer does not have wifi on it at all. This is an old laser printer. I have to connect it via USB to a machine that also has a wifi connection thus I never use AirPrint. Your step 1 doesn’t apply.

I did delete it from the system completely.

Then I downloaded and installed from scratch the appropriate HP drivers direct from HP for this printer.

I can connect it directly to the Catalina system via USB and got it working as a local printer.

Then I tried to reconnect it to my iMac and share it.

Still can’t get it to share across the wifi net. The printer is set to share across the network to everyone. The Linux machines can see and print to it. A guest’s Windows 10 machine can see and print to it.

On the Catalina system it shows up when I try to add a printer as HPLaserJetP1006@Oogies 2013 iMac with a kind of Bonjour Shared and the location is my iMac and the Use field is the correct HP driver but I get the same Unable to Verify printer error.

PS added later:

If I say go ahead and set up the printer anyway I can see it from within SW and gan select it as a device to print to.

The print goes to the queue and then sits there with a Printer in Use message and ever actually prints.

And more updates. I tried it the opposite way installing direct to Catalina system and print from the iMac. This time the error is Stopped Filter failed.

I have deleted and reset the entire printing system on both machines multiple times.

Ultimate is to resetting the printing system by right clicking in the printer area and select reset…

Already done that both directions, printer connected to Catalina, reset both systems and try to reinstall and printer connected to iMac, reset both systems and tried to install. Neither direction/way works. Fails with different errors though.

Both systems can print if the printer is directly connected via USB

It may just be a waiting game for Catalina to get its act together.


Finally decided to tackle the Apple tech support with the printing issue. First was getting through the wickets of the lower levels to get to the upper level support (I made it to level 3) only to be told that it will never work until both macs are running Catalina. It seems that Catalina won’t talk to older Mac operating systems in the print sharing world.

Next step was if the printer is connected to a Catalina computer can the Linux machines still see it and print and the answer is yes.

How about connecting the printer to the network so all computers can see it regardless if the hosting Mac is available or not? Assuming you haven’t done this because your printer is lacking an ethernet port or WiFi you could use a “Print server” like this: https://amzn.to/2DBGLqD

No ethernet port and no wifi and we actually tried setting it up on a dedicated machine runnig as a print server and had a whole hose of different errors but it still wouldn’t work.

The link that I included should take you to a USB > Ethernet print adapter / server :wink:

A brand new printer only cost twice that and gets us a new printer that is less than 10 years old. After hassling with it we jointly decided that throwing money at the problem was more cost effective than continuing to fight the mess.

1 Like

These Brothers work very nicely. If possible use the ethernet connection. Otherwise connect to your home WiFi. No more sharing from a Mac needed :wink:

I know it’s a Brother printer but since it’s hardware I turned the problem over to my husband so not entirely sure what model he’s getting. But it is going to be on the net for all the machines to use and also offers wifi/airprint options.

Disable the direct wireless printing option and connect to your own network. From there any device connected to that network will be able to see it. Wired or via WiFi.
If you have a outdoor wifi access point you can print from your iPhone while counting sheep :wink:

Actually we have ethernet cables run to the barn and multiple wifi access points that tie into our fiber optic fiber to the farm installation. What we haven;t yet installed is a way to extend the range of the wifi to the top of the lambing pasture. And believe me, that is somethign that is high on my list of enhancements I want! :stuck_out_tongue:

This will so the trick as long as you have a line of sight up to10miles if needed :slight_smile:


It is very seriuos matter and it is commendable for me. I am the user of a printer the brand is RIOCH for my home use and using this for the last 8 years. It works absolutely fine. It has the function of offline system aslo with outstanding performance. I would highly recommend you go for this printer Ricoh Printer Offline I hope this printer will suit your requirements.