iCloud Drive issues

Hi all,

a recent message by @chrisecurtis motivated me to write this post, to see if my symptoms are similar to his, and to see if other MPUs (can I use this TLA to say "Mac Power Users?) have ran into this issue.

This is the message I am referring to:

I too have been running into big issue with iCloud Drive ever since I performed the upgrade to Ventura 13.1.

Before then, things were running smooth for me, after that I started to get huge issues with bird daemon crashing all the time. The only workaround is disabling iCloud Drive, which gives me huge headaches in syncing between apps who use it to exchange data between the iOS, iPadOS and macOS versions of their apps.

I tweeted about my bad experience, and worked with Apple support on two, maybe three tickets, without getting past Level 1, so nothing has really changed at all.

Here is one such tweet:

In a nutshell, I am getting heaps of EXC_CRASH (SIGABRT) on bird, and can see all the dump of the crash from the Console, like so:

It looks bird is part of iCloud Drive, and deals with file synchronization.

And even if bird does NOT crash, the system is really sluggish, and things improve only after shutting down iCloud Drive. Which means losing sync across many apps, sadly.

In fact, I have turned on iCloud Drive for a few minutes, to test NotePlan sync over CloudKit, and unfortunately it looks like @metzgereduard, the developer for NotePlan, needs iCloud Drive and not just iCloud in order to have macOS sync with the mobile apps on iOS and iPadOS, bummer!

I have also found this interesting thread on StackExchange, but so far none of the tips helped:

Has anyone faced issues similar to mine with iCloud Drive?

@chrisecurtis are your symptoms similar? How were you able to let Apple investigate the issue more? I have been unable to get past the very unhelpful L1 support engineers, sadly…

Many thanks,


Are you identifying your version of macOS correctly? I updated to macOS 13.3.1 on April 7th. I’m not a big user of iCloud Drive, but I do sync with NotePan over CloudKit, and have not had problems.

hi @karlnyhus, yes I am, the issue is still very present with the current 13.3.1 macOS release, but it started only when I upgraded my Ventura setup to 13.1 a few months ago.

I don’t use much iCloud Drive directly, but many apps do use it to sync data, and now I have lost sync capability between the macOS app and the mobile counterpart on iPhone and iPad, and that’s not very nice nor useful.

I would at least like to have an inkling of an idea of where the issue comes from…

I was hoping a simple upgrade to the latest macOS might help. No such luck, eh? I’m afraid we’ll have to hope for Apple Support to come up with something for you.

I’m curious if this is an older Intel or Apple Silicon Mac? Good luck.

I’m not sure if this is the same issue, despite similar symptoms.

I had a very similar issue about 18 months ago, which took Apple 4 months to fix despite all available escalations, and there was never even a sliver of feedback as to the cause. I just noticed that files created anywhere in Documents (iCloud Drive enabled) or any of my iCloud folders (e.g. Pages, Numbers etc.), on any of my devices, simply stayed wherever they were. Apps and processes that used iCloud but did not directly use iCloud Drive (e.g. Photos, Calendar, Contacts and 3rd party apps like Diarly) all carried on as usual. The key piece of information was logging into iCloud.com to see that “Drive” would not allow me to view any folders at all. There was just a message saying there was an error accessing the folder and to try again later.

At no point has there been any error - or anything in the console logs.

It took about a day of being quietly and politely insistent (and wasting a lot of time on pointless level 1 procedures that I had already done) to escalate to a senior, then a week to get it escalated to engineering then NOTHING - for months despite me regularly checking in with the senior and him escalating it to his manager. Then one day everything started syncing again and a day later they were in touch to say that engineering “had done something” and checking that it was working.

It has been perfectly OK since then until I noticed that a file I created on my iPad had not synced to my Mac after several days. I checked into iCloud.com and saw that none of my Drive folders were accessible, but non-Drive iCloud is still working (including such things as backups)

This time it took only half an hour to escalate it to a senior, as the level 1 person recognised from the notes that I was describing the same thing. The senior tried a couple of things his end (“telling the account to refresh drive”), formally asked permission and read a disclaimer to give engineering permission to work on my account (and checked I had everything backed up outside iCloud) and said:

  1. It looks as if iCloud thinks you don’t have an account that gives you access to an iCloud Drive, but that’s obviously not the case and shouldn’t be possible.
  2. He had seen a few (single figures) similar examples in the last few years
  3. He escalated it to engineering (and talked about Cupertino)
  4. He said to give it a couple of weeks and he would get back to me because engineering were obliged to respond to him in 10 working days
  5. I missed his call (he phoned the day after we arranged and I was literally having a haircut) - currently trying to rearrange

Last time was utterly miserable. We were trying to buy a new house and I NEEDED iCloud Drive (e.g. for notes I made on site to be transferred to the Mac). The worst was simply no way of communicating with anyone to try to understand what was going on. Even the senior support people couldn’t get ANYTHING from engineering and I was not allowed to. I got a strong feeling that communication between the two was very poor.

I explained that I had local backup, so if they’d nuke my iCloud Drive and give me a blank working one, I could get it all back in a few hours. I asked them to make me a new iCloud account and let me transfer my stuff to it. All refused, but no explanation given. I didn’t even know if I was in a very long queue for a quick fix, or if it was a problem that was very hard to solve. I got to the point of sending Apple an initial formal letter to say that I thought they were infringing my statutory rights (UK law - they have to make “competent” and “reasonable” response to service issues and have to communicate to the customer to show that they are doing that - I have Apple One so have a service contract) They couldn’t have cared less: I was invited to serve a claim and given the relevant address, but told informally not to expect any response, ever. The people I dealt with were extremely helpful and the senior tech support people were impressively knowledgeable and understood instantly, but beyond them was a massive barrier, that they could not penetrate.

This time I am not so stressed. I moved all critical stuff out of iCloud Drive then and I have all the workarounds and more and more apps ignore iCloud Drive and sync their databases via iCloud instead. It’s just annoying and frustrating and makes me trust iCloud Drive even less.

Sorry that’s long. I hope it helps someone

1 Like

Have you tried the brctl command in Terminal? Here is a post by Howard Oakley that might help.

1 Like

that is what made the difference, @jec0047! I found about that command in the StackExchange article I posted above, and in this one too:

I fiddled with it a good amount, saw the issues with different processes including fileproviderd, and was able to sanitize my iCloud Drive thru a mix of good ol’ Unix CLI use, accessing iCloud Drive via the web interface, and throwing away a lot of cruft which had accumulated on iCloud Drive over the years.

My issue is now solved, and I am finally able to sync all my apps, again, after many months of jumping thru hoops by using Dropbox-based sync, which I am definitely NOT a fan of!

The main push for this effort is being finally able to sync across devices for NotePlan, which I installed today for testing after reading @metzgereduard in other threads, and seeing his creation mentioned elsewhere. NotePlan uses CloudKit sync, but somehow does not seem to work if iCloud Drive is not selected on macOS, which I believe is a bug. But it doesn’t matter any longer for me, now that I fixed things! :stuck_out_tongue_winking_eye:

That’s the spirit! Your contribution in the Bear 2 Beta thread gave me the kick to do more troubleshooting, and after a dozen of reboots or so, I was able to fix the issue, and my M1 MacBook Air is snappier than ever!

Thanks Mac Power Users! :+1:t2::muscle:t2::pray:t2:

1 Like

I’ve dug around in brctl dumps and watched the brctl log. It really does look as if my system is disconnected from iCloud Drive - it’s just waiting forever, without timeouts or errors, for a connection that isn’t made. Lots of other containers (e.g. cloudkit) are doing their thing.

As Apple Support says, there’s nothing I can do about that, at all, and I just need to hope that engineering sort out the problem fairly soon.

1 Like

I would buy another Mac and see if that one does the same thing. :rofl:

Given I have the same problem on my new iPad Pro and on my iPhone, I think that would be wishful thinking :wink:

1 Like