iMac G4 won’t turn on

Hi all. New to the group and hoping there may be someone out here with an answer I haven’t seen yet that’ll work for me.

I started an Apple collection this year and so far have picked up around 60 Apples/Macs of all kinds, from an Apple //e all the way up to my most recent vintage machine, a 2015 27” iMac.

Being a newbie to the ecosystem still, I don’t yet know all the tips and tricks though I’ve seen plenty for many things over the last few months.

My current problem that I haven’t yet found a solution for is a 15” iMac G4 I recently picked up off eBay “for parts”. The seller said it was parts only because he didn’t have a power cord to test it. I didn’t have this size screen yet, and I was hoping for the $70 shipped my gamble would pay off and I’d be able to resurrect it.

I plugged it in and tried powering it on when it arrived and obviously nothing. I’m using a cord from a working 17” model. Next, I unplugged it and held the power button in for 10 seconds, waited 10 seconds then tried again and nothing. Next I opened it up and dusted it out, reseated both ram chips and airport card, and checked to see if anything was unplugged internally that I could tell. I also replaced the 3.6v battery which was dead with a new one. Of course none of this made any difference. My last attempt today was to try resetting the PMU with the little switch under the motherboard next to the airport card. Nothing.

I’m afraid it’s officially dead unless one of you can suggest something I may have missed. Any ideas? Thanks in advance for any advice.


Can’t find a good pic, maybe a fuse on one of the power supply boards? (Probably a micro fuse)
Power supply would be my guess, unless you hear the one you have squeal from being overloaded.

There’s nothing whenever I’ve tried turning it on. No fan, no HD seeking, no squeal. Do you know where the fuse(s) would be located? First mention of that I’ve seen.

There is no fuse on the power supply…

A capacitor perhaps but not a fuse. I completely agree with JohnAlt about this being a Power Supply gone bad. That or the Logic Board shorted out.

When taking this model apart for the Power Supply or Logic Board to be replaced. Apple used a Torque driver that would prevent over tightening the screws. I believe it was set at 18 lbs torque, but it has been years since I have had to open a G4 iMac.

Might be cheaper to find another one that works.

That’s what I was afraid of. At least the 15” models are pretty common. Maybe I can part this one out or something.

I’m having the same issue exactly with a mirrored door PowerMac G4 I picked up as untested. Not sure if I’ve exhausted all of the steps above though. I’ll have to try that one a few more times.

Thankfully most other “untested” machines I’ve gambled on I’ve gotten back to life - including a 400MHz Pismo PowerBook G3 yesterday. :blush:

There’s always a fuse somewhere :slight_smile:

Found this mention:

it turns out the fuse is a built-in 250 V - 8 amp ceramic fuse and proximal to where the power cord enters the PSU

You are correct… but most people hope for a removable fuse. Not something soldered on to a board.