iMac Pro gets hot during sleep

I put one of our iMac Pros on a power monitor to help me understand why it gets warm when it’s sleeping. When I put it to sleep (Apple menu->sleep) the display turns off and the power utilization drops, after 10 or 15 seconds, down to 5 watts or so. It then jumps immediately back up into the 50 watt range and stays there. This is despite both the display and the fans being off. So of course it gets hot.

Turning off power nap and wake for network access doesn’t make any difference. SMC and PRAM resets don’t make any difference. What does fix the problem for me is unplugging the Ethernet cable. WiFi is fine. Ethernet is not. Unfortunately I don’t really trust WiFi for things like backups and we have a house with a lot of concrete in it which makes coverage iffy so this isn’t a great solution for me. Has anyone else seen this and found a workaround?

There’s a fairly long thread about this over on

That’s where I picked up the suggestion to try sleeping without Ethernet. What I’m not seeing there is any consensus on what works for everyone and what’s going to work long-term. I suspect, as others suggested there, that this isn’t a hardware issue. I don’t think that our other iMac Pro did this when we first got it, but I’ve noticed it off and on since one of the updates earlier this year (maybe 10.13.4?). I just tried the monitor on it and it exhibits the same behavior.

I guess my next step would be to call Apple, but that thread isn’t giving me a warm feeling there either. Help?

Have you tried turning on do not disturb?
Seems to be a problem with laptops too.

That looks annoying. I don’t use notifications on macOS though - at least not willingly. It’s my place to get away from all of that. So there weren’t any and turning on do not disturb didn’t help. Thanks for the suggestion.

Hmm… Guess I should have posted this in tech support? Oops. Moved.

That does not sound good, and it’s very interesstng that you find this to be the ethernet cable. It might sound backwards, but do you have the possibility to try with a Ethernet to USB-A adapter, and see if the behaviour is the same?

My other suggestion is following Apple’s knowledge base article about this issue. Here it says:

If your Mac wakes unexpectedly

Your Mac might wake for these activities:

  • Network activity that uses the Wake on Demand feature. Examples of network activity include iTunes sharing, photo sharing, printer sharing, file sharing, and using Back to My Mac.
  • Enhanced notifications from FaceTime, Messages, and other apps and services.
  • Bluetooth activity. To prevent Bluetooth devices from waking your Mac, choose Apple menu > System Preferences, then click Bluetooth. Click the Advanced Button, then deselect “Allow Bluetooth devices to wake this computer.”

So - check this. Also, do the remaining general troubleshooting:

If the previous steps don’t work

  • Disconnect external devices other than your Apple keyboard, mouse, and display. If that resolves the issue, gradually reconnect your devices, testing each time, until you find the device that is interfering with sleep. Then check the documentation that came with the device, or contact the device manufacturer.
  • Start up in Safe Mode to see if the issue is related to non-Apple startup items, login items, or kernel extensions.
  • Try to isolate the issue by using another user account.

So, there is a few things left to check and see how it behaves. Either way, if you’ve done all the steps in the article, I would call or chat with Apple support to report this issue. If they won’t resolve it, they’ll report it and hopefully, if it’s a software bug, it will be fixed the next time around.

I have a USB-C to Ethernet adapter on order and will check to see how it compares. I do see that the system behaves correctly if I use WiFi instead of Ethernet.

This is a machine that only has Apple software on it (what it shipped with plus updates). I haven’t enabled iCloud on it or any other sharing services and turned on so I don’t think that’s an issue. Turning on “do not disturb” doesn’t change the behavior. I did try turning off Bluetooth wakeups and using a wired keyboard instead. It didn’t make any difference.

The thing that really concerns me about this is that when the system goes to “sleep” the fans turn off. Then the internals come back on and heat up with the fans still off. That’s a dangerous combination. I will try Apple support next. Thanks.

Could you perform a traffic analysis? Haven’t used it, but something like little snitch?

That’s an interesting idea - especially given that my stepson’s chronically virus-ridden Windows PC is on the network. I haven’t used Little Snitch either but I used to do this on an old Linux machine and there’s enough stuff going on even with a few machines active that I don’t know I’d have much luck isolating a cause.

However, this is MPU and that means that I have an extra router in the closet. I tried hooking one of the iMac Pros up to it, isolated from the rest of the network. So it’s just this machine and the router on their network. The iMac Pro still ends up in the same bad state.

I don’t think it’s related to network traffic. Trying this some more I see that sometimes it successfully goes to sleep. Once it’s there it stays there. If it’s not going to it comes back out of sleep immediately. It’s acting more like a race condition. Unfortunately it ends up in this bad state (internals on/fans off) the majority of the time if it’s connected to Ethernet.

The thing that’s concerning me is not so much that the machine wakes up from sleep (although it shouldn’t). It’s that it wakes up, and stays awake drawing normal idle power, without the fans active, causing the internals to get much hotter than they do during normal operation. I can’t imagine a normal working state that should cause that to happen.

Hm. Do you have iStat Menus installed?
You could check cpu, SSD, etc. temperatures, for peace of mind, or to know if leaving Ethernet unplugged or shutdown is warranted.

Another idea, have you tried turning off the Ethernet port with the cable still connected?

I do have iStat Menus installed. That’s part of why I started getting worried. Internal temperatures sometimes get up into the 140 to 150F range if the machine sits like this overnight.

I talked to Apple Support this afternoon. They’re aware that there’s a problem but there may be some debate over how widespread it is. I’ve collected/forwarded on some data showing the behavior on both of these systems. I suspect that’s not going to get much attention while they’re pushing out a new release but maybe after that…

1 Like

I haven’t tried this myself yet, but I’m told by another iMac Pro owner who was seeing the same symptoms that this problem is fixed by the firmware update that ships with Mojave. I’m not an early update kind of guy and using an USB-3 to Ethernet adapter allows me to avoid the problem for now so I’m going to wait a bit to try it myself.

Mini-rant: I went back and forth with Apple Support on this - including sending in logs that they forwarded on to Apple Engineering. They eventually got back to me with a claim that it was because my router was flooding our network with WOL packets. I ran a traffic analysis (Wireshark is great for this) and… nothing. Telling me that it was fixed in Mojave would have been so much simpler for all of us.

I brought this to Apple’s attention in February 2018. I spent at least 5-6 hours speaking with various senior support staff to diagnose the issue and relay to their developers. The consensus is that no one at Apple really cares, as demonstrated by their lack of action. It’s very frustrating that I wasted so much time with them. A $10,000 computer that can’t even sleep properly.