iMac slows over time until it crashes; After "Nuke & Pave," cycle repeats

Summary: My iMac repeatedly slows down & gets bogged down over time until it eventually crashes in one way or another. After a “nuke & pave” the cycle eventually repeats. I’m wondering if any of the third party apps listed below (apps recommended and/or discussed on MPU) might be contributing.

Details: Since purchasing my iMac (Retina 5K, 27-inch, mid-2017 - 1TB Fusion Drive) in January 2019 it seems to get progressively slower and bogs down over a period of months until it eventually crashes. “Crashes” include either running so slow that I often have to restart, or keyboard input becoming unbearably slow - I type and wait, or, most recently, the iMac refused to boot up all together. Since January 2019 this cycle has happened three or four times, and each time I end up calling apple Tech Support and ultimately they tell me to wipe the HD and do a clean OS install. At first the computer seems to run fine, but then after a few months I notice the symptoms slowly starting - spinning beach ball more often, frequent pauses during keyboard input, etc., long reboot times. And the Mail begins taking longer and longer to start up - first 15 secs, then 30 secs, and eventually as long as 1 min or a minute and a half to fully load. Doing searches in Mail or Notes produce no results. As the sluggishness progresses, the computer begins taking longer and longer to reboot after a restart, recently taking up to twenty minutes to fully reboot and load all of the third part apps I have installed.

The first time I talked to Apple they had me take it a Genius bar where they concluded that having two types of RAM installed was the problem and so removed two RAM chips leaving 2 at 16 GB each. The problem eventually returned. Apple now insists that it is likely due to one or more third party apps I’m running. Since most of the third party apps I run are those commonly discussed or recommended on MPU, I’m wondering if anyone else has experienced the problem I’m having or if you have had similar issues while running any of the apps I’ve listed below. Thanks for any insight you are able to provide!

I do keep my Mac updated to the latest OS version. Apple had me run hardware tests and everything checked out. They also installed the “Profile” system preference which monitored the computer and then I sent them the files to analyze, but they found nothing.

In a nutshell: Has anyone experienced a gradual slow down in their Mac’s performance and eventual crashing in one form or another due to any of these apps? Thanks much!!

CleanMyMac X
Day 1
Dropzone 3
Keyboard Maestro
Omni Apps / OmniSync
Pixelmator / Pixelmator Pro
Resilio Sync
SmallCubed Mail Suite (I only have Mail Act-On installed)
Text Expander

I would recommend running something to actively protect against malware, such as Malwarebytes.

Historically, having a lot of stuff on your desktop can lead to slowdowns, so something to keep an eye on too.

1 Like

Thanks for the suggestions! Yes, I have Malwarebytes (free version) which I run from time to time, especially when issues arise. So far haven’t found anything.

How full is your drive? Your symptoms match over full drive symptoms.

Then I would check the size of your fusion drive, Sounds like you may have upgraded your RAM - if your RAM is larger than the SSD in your fusion drive, then it can work much less well. At the beginning of Fusion drives the SSD part was pretty large, but more recently, if your BTO option had small RAM the SSD part could be smaller than the max ram of the computer, and if the RAM got updated to larger than the SSD, then that could cause problems.

Check the speed of an external SSD - would that be reasonable to boot off if you had it velcro’d to the back of the computer? It might be okay. Opening iMacs is not for the faint of heart.

1 Like

It may be an issue with your working set of apps being too large for the size of the SSD of the fusion drive. Your fusion drive only has a 24 or 32gb SSD (never can remember which models have which size) as opposed to the 128gb SSD on the 2 & 3tb models. As you load more apps and have them running most of the time they won’t fit on the SSD and have to be loaded from the spinning drive. That also means that your data is likely coming from the spinning drive. I don’t know of any tools to determine whether this is the case.

How is your memory pressure? With 32gb I would doubt it’s a problem but always good to verify. Memory chip problems usually manifest differently. Won’t start or system instability. Had that problem on my wife’s iMac with 8gb of Apple ram and 32gb of OWC ram. Now running just the OWC and it does fine.

Activity Monitor is your best tool right now. Start it up and start doing your normal stuff. As you notice sluggishness check memory, CPU, and disk activity.

1 Like

I’d recommend doing a hardware analysis as well
Apple hardware diagnostics is a good start (press D on startup)

1 Like

Your problem sounds so frustrating… I don’t know if it’s the same thing, but I had a similar experience, most recently as 18 months ago. My MacBook Pro would slow down over time until finally there was this point of crisis and then it was time for break the glass and pull the lever. I went through at least two cycles of slow down and then nuke and pave. I wish I had documented everything better but such is the nature of crisis.

The problem seemed to present as a bloat issue, my hard drive (ssd) was full. I would repeatedly chastise myself for not being more careful with storage. But in this case, it wasn’t really my fault. What I finally determined was that it had to do with the interaction of Apple’s new security approach in OSX and the backup software I was using, CloudBerry Backup. What’s important to know is that other backup software applications were sometimes doing the same thing, it wasn’t just Cloudberry. They would (do?) get confused with volume identities. At least, that’s what I read as I scoured various forums and online help. I don’t know how widespread the issue was (is) but I’m fairly certain it happened to me.

My Apple System Report on storage showed my ssd to be full. But when I used other utility apps to look at my drive I could only identify about 35% of what was on the drive. I was trying to figure out what was taking up 60% of my drive and it was strange. My layman explanation will struggle here… Apple has (partitioned?) or separated certain system files, made them less visible, and Cloudberry backup would confuse them as a separate volume and then copy them over on my laptop ssd. I don’ t understand this but I’ve read that it has sometimes happens and with Time Machine also. I don’t remember the utility I used to spot these copies but once I removed them the crisis was over.

Part of my recovery was reworking my backup workflow. I stopped using Cloudberry and switched to Arq 5. I worked on the connection issues I was having with my NAS (QNAP 420) by making OSX go into a server or NAS mode. It’s a (hidden?) software switch from some previous time that can be accessed through terminal. I started monitoring my drives and have been watching for any signs of abnormal growth.

1 Like

If you can determine that it’s the fusion drive causing slowness, Here’s an article on using an external SSD.

1 Like

This case looks amazing. OWC Envoy Express Thunderbolt 3 Bus-Powered... at


It looks good, but I’m leery of permanently-attached cables after the cable on my first Sabrent Rocket XTRM failed. They replaced it with the newer model, which has a detachable cable. I have since bought another, and haven’t had any problems with either of them.

1 Like

Thanks for the feedback. This is helpful, although on this Mac I only backup using an external Time Machine drive. Indeed the problem may be my overly full HD.