Impossible to format external drive

A friend of mine bought an external Seagate 5 TB drive. He kept it formatted as exFat, and it worked good for a day or so. But today it doesn’t mount. So I am trying to help him format it again (as APSF), but it is impossible.

I have tried with Disk Utility and with diskutil in Terminal, to no avail. Some facts:

  • In Disk Utility, the disk (named “Server”) is greyed out.
  • Trying to erase it* shows after a while that it couldn’t unmount the drive (error 69879).
    *I have tried both the volume as well as the actual disk.
  • All actions in Disk Utility gives the error “Can’t unmount the drive”.
  • In Terminal I have similar problems. diskutil eraseDisk gives “Couldn’t unmount disk”
  • diskutil unmountDisk force disk2 actually works. If I then do a “diskutil eraseVolume HFS+ Server disk2” it starts to erase it, but after 20% or so it cancels with Error: -69888: Couldn’t unmount disk

I also tried a cs list, but it couldn’t find any (ie encrypted partitions).

Please note that the disk is NOT mounted in any way (as I said, it’s greyed out in Disk Utility). I suspect that macOS is trying to talk to the volume and thus occupies it in some way.

So, any ideas…? :crazy_face:

1 Like

This happened to me a while back. As I recall Disk Utility should allow you to format the device as Mac OS extended (Journaled) . Once that is done you can re-format as APFS.

Ok, will try that. :+1:

Followup: Didn’t work. Still errors with “Couldn’t unmount drive”.

So I put the drive in my Parallells Windows 11 installation, and it immediately said: “Errors found, do you want to scan the drive?”.
So I’m currently waiting for it to scan and repair. My guess is that the drive is faulty, otherwise macOS should be able to format it.


1 Like

Alright. Windows 11 managed to repair the disk.
After that I used Disk Utility to erase it with APFS. Everything seems to work as intended.

I have never seen this behavior before, really really strange. :thinking: Is there something with exFat that could lock macOS somehow?