In iCloud hell, i am

Started processing and importing lots of photos and video to Photos on my new M1 MB Air. Library file currently sitting at 242.89GB. Uploads seemed to be stuck, so I signed out of iCloud, then signed back in. Photos then popped up a window about upgrading my storage plan size even though my plan showed 100 out of 200GB still free. I guess Photos could tell I would go over eventually.

So I upgraded my plan (this was inevitable) but Photos seemed to be stuck on updating. So I quit it, then repaired the library. Now it’s stuck on ‘restoring’ sigh

Any ideas? Any hacks or fixes?

All I know is that syncing iCloud and Photos has always taken a very long (undefined) time for me on new devices. Lay it up to Apple throttling, or whatever. I’ve learned to just make sure there’s enough capacity locally and in the cloud, ensure I’m on the best network bandwidth I can find – aren’t you usually on an RV park network or something? Then start the process and go do something else for a day or so. Stopping and starting up or starting over seems to irritate the Apple gods, and then things really slow down.

3 Likes

RV park 30mbps down/up :man_shrugging:

Yep. This is one you put in the oven and let bake until it’s done.

3 Likes

256 GB of data at 30MPBS would take about 19 hours, wall time, assuming no overhead for verification, pauses, and other network background activity. And, assuming nothing else at all will take a slice of the bandwidth. So, realistically, the process might take twice as long - closer to 40 hours.

Or you could go visit a cousin who has gigabit ethernet, plug in and get this done in an hour.

2 Likes

Right now it indicates ‘Restoring from iCloud’ - and yet my library file has gone up only .01GB in four hours. So what, exactly, is being restored? iCloud photos is showing 14.8GB, which is not much larger than yesterday, if any.

How can I determine if anything is actually either uploading or downloading?

nearest cousin is almost 1200 miles away. I will be at my brother’s house in 2 weeks, not sure how fast his speeds are but should be good.

This might be unhelpful as I’m not in front of a Mac, but have a look in Activity Monitor for something that looks like a Photos process and see if it is using any network resources (and if not, see what is).

1 Like

I had iCloud hell problems early last week when I set up my new MBP.

Here's a rant.

When I first set up my MBP, I went into iCloud Drive, and it was totally empty. Here’s what I tried:

  • restart
  • logged out of icloud + restarted
  • killall bird, as per macos - iCloud Drive Won't Sync on Mac - Ask Different
  • reset metadata cache, following the same steps in the above post
  • created a new user account
  • formatted macOS and reinstalled macOS
  • set up the Mac via macOS via Migration Assistant through my Mac mini

I even did some deep spelunking: the terminal command brctl log -w logs the ‘bird’ process, which governs iCloud syncing activity. It showed a repeating error (broadcasting to framework clients container <private> change BRContainerlastServerUpdateKey=Fri Dec 29 18:42:28 0000) identical to these two posts:

iCloud files not appearing on Mac - Apple Community

Documents and Desktop from iCloud not bei… - Apple Community

I then called Apple Support, who spent twenty minutes double-checking that I wasn’t just clicking on the wrong “Desktop” and “Downloads” folder. They then told me it was a “known issue with Monterey.” (I don’t think this was actually true.)

I gave up, and the next day it sorta started working. iCloud Drive files were showing up, but then new ones weren’t uploading. So, I waited another day, and it eventually became stable and instant.

:man_shrugging:t2:

At the same time, I was also selling both my old MBP and my Mac mini at the time. On both computers, I literally couldn’t sign out of my Apple ID. It gave me a Preferences Error: There was an error in Apple ID Preferences. error. Resetting the System Preferences .plist file didn’t work, nor did booting into Safe Mode. I eventually just wiped the Macs and shipped them off…

…but wait, because when I used System Recovery to format the drives on each and to reinstall macOS, both Macs totally failed the local reinstall, somehow erasing the internal recovery partition. (I swear I followed the steps exactly…) So, I ended up waiting through the “spinning globe of hope” in Internet Recovery Mode. Both ended up working, thankfully.

thank you for coming to my TED talk

(TL;DR: Wait and it will stop being broken.)

So, I am sorry to hear about the trouble. I guess just count me in as sympathetic. Sometimes iCloud really doesn’t “just work.” (That, or there’s something deeply wrong with my Apple ID…)

1 Like

Also, is that 30 just you? Or is that shared with the park?

I agree that you should look and see what’s using bandwidth, if anything.

2 Likes

Speedtest might be helpful from the target computer to see how much bandwidth you are actually getting.

1 Like

Now showing 29down, 2up. But bird was showing zero network activity. Nothing icloud-related showing any network activity. :frowning:

Check Finder’s Info pane for the Pictures folder and see if it increases in size.

If nothing’s happening maybe log out of iCloud on the Mac, reboot, log back-in, wait until iCloud settles down, and then try the photos sync again.

1 Like

yeah, already did the whole log out/reboot/log in thing this morning - but thanks

logged out/logged in/rebooted. Again.

Re-checked the box for Desktop/Documents in iCloud.

Re-checked the box for iCloud in iPhotos.

Documents are not downloading from iCloud.

Photos is ‘updating’. Again.

EDIT: Photos is now ‘uploading’ 4,562 items. No process name in Activity Monitor has sent more than 1.7MB of data. Bird has sent/received zero bytes.

follow-up: switched to Disk activity panel - bird has written over 7GB of data and the number is slowly climbing. Unsure why this isn’t registering in the Network panel, but at least something seems to be happening. Photos app shows a progress bar. iCloud Drive in Finder shows no progress indicator.

Think I’ll leave this overnight again and see if anything looks different in the A.M.

EDIT: photos are syncing, Documents are downloading. All is well!

3 Likes

Narrator voice: “All was not, in fact, well!”

Photos ‘uploading’ did not actually upload a single file overnight. Tried pausing and resuming this morning. Still nothing. So I tried repairing the library again. It then did the whole ‘restoring from icloud’ thing, and I watched theh library size grow back to … well, almost its original size. Photos still says it is restoring but nothing is changing anywhere.

As much as I hate splitting things up between two services, I’m fairly close to just chucking iCloud for anything but data that apps store there, put all my files in Google Drive and Google Photos and keep nothing in Apple Photos but the last 30 days of Photostream. Will have to have a big training session with the wife on making sure everything gets synced up and on how to find things. Simplification be damned!

What kind of Wi-Fi do you have? I’ve been relying on tethering to my iPhone when I need my Mac online and while iCloud synching works for most things it does not work for Photos uploading or downloading. So, if you’re using any kind of hotspot connection that shows up as the two interconnected circles instead of standard Wi-Fi bars in the menu bar that might be your issue.

I primarily use iCloud Drive for my business and personal purposes. I do have subscriptions to Google Workspace and Microsoft 365 and use their cloud services as well.

I just purchased a new M1 Pro MBP and noticed there is a difference in the initial iCloud Drive sync vs the other services. On Google Drive and OneDrive, I was able to see the folder / file structure very quickly, but it took several hours for sync to complete. On iCloud Drive I didn’t see ANYTHING for several hours, then everything populated at once, including the full file downloads and photos.

Please note that I am on a 1GB download speed, so my times would be less than yours.

TL;DR…have patience, it should work out OK

1 Like

I’ve been trying the park WiFi and AT&T (my own hotspot) - now trying my iPhone tethering, since you mentioned it (Verizon plan is truly unlimited, no throttling). Photos is still stuck, or at least appears to be, but how would I know because APPLE DOES NOT WANT TO GIVE ME ANY INDICATION OF STATUS