Input Menu Missing?

Hey MPU,

I have been trying to figure this out and I can’t wrap my brain around it. I am taking an Intro to Greek Class this semester. I added Greek via System Preferences > Language & Region > Keyboard. I also have the box checked for “Show input menu in menu bar”…There’s no flag in my menu bar!!! I quit Bartender in case there was something there missing, but that didn’t help. Any other suggestions?

I have never done something like that but I just tried to add the Greek keyboard to my system (MacOS Catalina, German system) and the German flag immediately showed up in the menu bar. Then I was able to change it to Greek.

Unfortunately, I was not able to type with Greek letters on my German keyboard… That might be an issue I have caused because of using CleanMyMac (removing language files from the system that are “not necessary”), I am not sure about that, though.

My Bartender settings for Text Input are: Menu bar item should: Show.

Maybe someone else has an idea what is going on…

Finally got it figured out and I am not sure how this happened.

These 3 items were using the same keyboard shortcut

  1. Spotlight Search
  2. Alfred Search
  3. Siri.

I reset all 3 to their originals. I re-added the keyboards and checked the input menu box.
I restarted my mac and now I can see the flag(s) again. :white_check_mark:

1 Like

I hate it when that happens - and that has happened to me before, too (not with Spotlight, but with 1Password and Keyboard Maestro). :slight_smile:

Good to hear that you were able to figure it out! Stuff like that is not easy to find…