IOS Shortcuts “Access Token Expired”

I recently was working on some shortcuts on iOS 13.2. Everything was working fine, then I taught my class and when I cam out I tried to test a shortcut I was working on and when opening Shortcuts, it crashed…every time. So I used @MacSparky ’s rule for iOS troubleshooting. I closed the app - didn’t help - then I restarted iPad - didn’t help - then I deleted and reinstalled the app.

Now I get the “Access Token” error on SOME of my Shortcuts. There doesn’t seem to be a rhyme or reason here. Some shortcuts I made, others were “untrusted” additions. No permissions are needed.

The error seems to be associated with the Share Sheet, as I can “copy” the “Shortcut Input” and then run it in the Shortcuts app and it works fine, but through the Sharesheet it does not and gets the Access Token error?

Is there a way to manually reset the “tokens?” Am I missing something.

More people have this issue

What worked for me:

  1. Backup the shortcuts (you have a shortcut for that, don’t you?)
  2. Delete all my shortcuts
  3. Delete the shortcut app
  4. Hard reset (iPhone 8: sequence and keep holding the Button for power down to black screen > white boot screen > back to black screen (takes about 10-15 seconds for the entire sequence)
  5. Power up the phone
  6. Add back the Shortcuts App
  7. Add back the Shortcuts including the one caused the message of expired token