iPad (Pro 10.5”) battery drain

The last couple of weeks the battery of my iPad Pro 10.5” (running iOS 15.5) is draining when I’m not using it: during a night or day in the office, about 8 hours, it drains by over 30%. According to the Battery info in Settings it’s “Find my” that’s using 100% off every hour.

This might have started when I purchased a HomePod mini and change some settings.


something definitely not right, I just checked my iPad mini 6 , Find my is only using 3 %. I presume you have rebooted the iPad already?

I have not had this issue with Find My, but with a lot of other apps and system services over the years on many iDevices and several iOS/iPadOS versions. Something seems to be stuck.

The IT Crowd’s motto might be the best help:

Have you turned if off and on again?

I would start turning the iPad off and back on again.

If it does not help:

And after that: Disable the system services for Find My.

Settings > Privacy > Location Services > System Services > Find My

It might be of help to wait some hours after each step to see if it has any impact.

Regarding your particular issue:


If everything fails (I do not really think that the HomePod has caused this issue, but you never know):

(Removing the HomePod from your Home and adding it again afterwards.)

1 Like

You might be right!

Most of the people in the article you linked have AirTag(s). So do I…

I also own AirTags. But I do not have any issues at all with any device draining my battery because of Find My.

I was referring to the article on Apple’s discussion boards not so much because of AirTags but because of the answer Apple has recommended:

Have you checked the following setting?

Settings > Privacy > Location Services > System Services > Find My iPhone

Here are some articles that may help.

Restarting devices, disabling and enabling services, some debugging as described in the articles should solve the issue.

Something in Find My or on your iPad is acting up and I think it should be possible to get it back on track. :slight_smile:

I already (partially) tried that (restarting, disabling “Find my” functionality, 1-by-1) before posting, but without success.

Maybe I should try turning Bluetooth off next?

And as a last resort you might try resetting all network settings. You will have to log back into WiFi, etc. after doing this so have all your credentials handy.

1 Like

What happens when you disable Settings > Privacy > Location Services > System Services > Find My iPad and leave it disabled?

Is the iPad still showing 100% battery use even when not in use and if so, is it still Find My showing 100% activity during those times?

I just checked my iPad Pro Battery stats. Everything was fine during the last 5 days. BUT :wink: Find My indeed was acting up last weekend for 4 days: 100% battery use on my iPad Pro 24/7 with Find My being responsible for 93%.

I did not notice the issue, I have to say (I thought that I might have forgotten to charge the iPad on time). What did I do to resolve the issue? Because the battery was depleted, the iPad was turned off automatically. I charged the iPad… That’s it. Battery use since then normal (I have not used the iPad on Thursday, battery use one Thursday: a tiny green line indicates that it has used the battery just a tiny bit).

I really think that sometimes processes/services or apps get stuck on our iDevices. And yes, Find My might be a prime example for it. Turning the device off, disabling a service (and enabling it again after a day or so), deleting an app and installing it again, all those things always have helped me. And unfortunately there is not much more you can do. Apart from the more severe options like resetting all network settings, restoring the iPad from a backup or even setting the iPad up as a “new device”…

One of the things I tried, without any luck.

Interesting: I stayed at family yesterday and the iPad (with all related settings turned on) lost 0% (yes, zero!) over 9 hours.

What’s different (at first sight)?

  • Away from my HomePod
  • iPad and AirTag (in backpack) were on different floors

Seems like I have new parameters to “play” with…

Yes, I get reminded of that on my iPhone, every single day…

There’s a Health related process stuck on it and I have yet to find a way to fix this without risking data loss (multiple years of health data).

(Symptoms: unable to export Health data, Health being the top battery user when I don’t use my iPhone)