iPhone Text Message notifications inaudible and missing

Sicne version 16 of iOS I’ve lost something in text message notificaitons. Not only do the never ping when the phone is in use but the volume is a lot lower. Iv;e checked and I have notificatinns set, have my preferred sound and the volume is turned up all the way but if the phone is in my belt pouch I can’t even hear the text message beep at all now. Yet the ring sound is still nice and loud.

Worse, if i am doing somehtign on my phone and I get a message there is nothing audible to indicate it came in. I used to get the same loud beep anytime a message arrived. I LIKE the interruption of a text message sound even if I am doing something because the only times I get text messages is when they are urgent so I want them to grab my attention.

How can I get the old behavior back?

I need both louder beeps and I want them no matter what else I am doing on the phone at the time.

Have you tried increasing the volume under Settings | Sounds, and turning off Change with Buttons?

You can also have notifications repeat, which might be helpful.

Yes, I have it up as high as it can go, change with buttons off and have it repeat 3 times.

Message notifications are still very soft and do not show up if I am doing something else on the phone at the time it comes in. Yet my phone ring is nice and loud and interrupts whatever I am doing. Which is exactly as it should.

this is where the Apple watch can be really handy. I hardly notice notification on my iPhone as it is not always besides me, especially when I am home. I wear my Apple watch 20 hours in a day except when it is on the charger

Don’t have one. Watches are not compatible with my style of farming. My phone is always with me in a pouch in my belt though so I always have it. At night it’s on the bedstand beside me but set to no notifications.

You may have to re-visit that with Watch Ultra, should be rugged enough to survive ? but it may not pass your fashion styling minimum standard :sweat_smile:

Try in this order,

  1. Fiddle with the settings > notifications > messages
  2. Turn off and back on
  3. factory reset
  4. Genius Bar
  5. buy airpods (turn on announce in your notification) / watch
  6. buy a new phone :crossed_fingers:

I had the same thing happen. I tried a lot of things, but ultimately what fixed it was erasing/restoring my phone from a backup. It was a pain, but it’s working great now.

1 Like

Can you try using the same sound for texts as you use for phone calls? Wonder if the volume would be different?

(Grasping at straws, but that’s where we are.)

I have exactly the same problem, which is a real pain when I’m on call for work.

Things I have noticed:

  • iMessage alerts ping as they should, it’s only SMS that seem to get ‘swallowed’.
  • Sometimes I will get the alert, but usually only if I have just been looking at Messages on my phone, or if I am actually using my phone when it arrives.
  • I have checked and double checked all my notification settings on iPhone and Apple watch and they are all as they should be… as evidenced by the previous post, where they do arrive and make a noise.
  • When there is no noise, it’s because there is no notification at all. The only evidence something has arrived is a badge on the Messages icon.
  • Other notification types arrive with banners and pings as they should.

In other words, it is many, even most SMS alerts that just don’t get alerted. Everything else does what it should.

Well at least I have that as an option, I guess.

There is also the setting to allow notifications from unknown senders that hasn’t been mentioned yet.

I don’t have those options. Only option I see under messages customize notifications is the repeat option.

Plus, I am missing messages from people I get messages from regularly, like my husband.

1 Like

What model phone are you on? My Mother has had this bug for over a year now, on an iPhone 7. She refuses to let me do a factory reset so I don’t know if that would fix the problem, but subsequent iOS updates haven’t fixed it, and neither does turning it off and on again. Luckily she is on her phone a lot and the red notification icon still shows so she does usually notice eventually if someone has texted :roll_eyes:

13 Pro so a fairly recent one.

I’ve been fighting this for a year now, and I only just now realized (thanks to your comment here) that it’s only some SMS messages that I don’t get notified about. iMessage alerts seem to come through just fine.

Such a weird little bug!

1 Like

Nor me. Is it a US-only thing? Only a guess based on those other two switches, which would seem to need some kind of integration with… something.

Let’s all report this to Apple. Via feedback… I wouldn’t wish phone support on my enemies, let alone the fine people here.

I’m in the US so not a US only thing.

I’m looking back and I am not sure but I think mine are mostly SMS messages that I don’t get notified about as well. I’ll have topay more attention in future and see.

1 Like