Issue with external hard drive on new mini using Mojave

BLUF (since this got to be longer than I expected) : setting up new Mac mini with a fresh install, using old hard drives from prior mini, and seeing lots of permissions errors under Mojave.

Hello! I recently purchased a Mac mini 2018 and have been setting it up fresh rather than using Set-Up Assistant from my old 2011 mini.

I use two external 4 Gb drives: one for Time Machine and the other for holding all data except iCloud documents. On the old mini I had zero issues. The new mini, though, has been giving me some problems.

After I set up my user account on the new mini, I just plugged the old hard drives in, pointed Time Machine to one external, and iTunes to the other. Things ran fine the first night, although the Time Machine backup started a new file rather than picking up from the old because I inadvertently named the new mini a different name from the old one (or maybe that’s just how it does, not sure).

The problems started the next evening. I logged in and went to open iTunes and received an error stating the hard disk was locked and to choose a file or start a new one. Most of the solutions I saw related to fixing permissions. Sure enough the permissions were either missing or read only. I tried fixing permissions and clicking to apply to all sub-items, but still no joy. What finally worked was to move the .itl file to the desktop, quit iTunes, and then open it. Then, take the new .itl file it just created, delete it, and move in the one from the desktop. That did the trick.

But as I’ve used the machine I’m noticing more errors. For example, I ran a Gemini II duplicate search and when I went to select some files to delete it popped up an error saying I didn’t have permission. Sure enough, even though I’d clicked to apply permissions to the entire drive, they had not changed on the particular folder from which I was trying to delete. I fixed that, then went back to try and delete and got the same error. I ran disk first-aid, shutdown and restarted Gemini II, unmounted and remounted the drive and I’m still getting the same errors.

I’ve since experimented and noticed that permissions are different for every single item even after I’ve selected to apply to enclosed items.

The other strange thing is that, even though it’s set up, I have yet to see my Apple Watch unlock my account.

At this point I’m not sure what’s going on, nor what to do about it and hope that one of you might have run across this before. I’m wondering if it might be something with Mojave. Speaking of which, the internal mini drive is APFS with File Vault enabled, the externals are Mac OS Extended (Journaled) without encryption.

I haven’t gotten too far with the new setup, so if I need to delete everything and run migration assistant from one of the old Time Machine backups, I can certainly do that.


For what it is worth I had the same issues when I upgraded my iMac in 2017. I brought a new iMac in 2017 to replace my older 2011 iMac. I moved the external hard drives I had over to the new iMac and had endless issues with them not mounting and once mounted they would simply disappear all by themselves. I did the usual troubleshooting and even had Apple support in on the FUN. I finally just brought new external hard drives and the problem was solved. It turned out to be a driver issue. I am still using the new external drives I brought with no mounting issues.

Barry, thank you—that’s very helpful! When you moved the data over to the new drives did you just do a straight copy? And no errors showed up once the data was on the new drives?

This is just a wild guess, and I’m not sure what you would to to fix it, but it might be that your old setup was using AFP, which I believe is now deprecated in favor of SMB.

Yes, I just mounted the old drives and copied over the data to the new drives. For my Time Machine drive I just started over with the new drive. One thing to remember about Time Machine is that it is designed to provide “recent “ data recovery and was never meant to provide archive style storage of files forever. If you want archive type storage there are better solutions that are available.