Issue with function keys on new MBP2021

Hi all,

I have a new 2021 MBP. I have the F keys set as default, by which I mean that the symbols relate to the keys and, if I need to use an actual F key, I need to hold the Fn button as well.

The keys are working perfectly, save for three. F1 and F2 work for screen brightness, as they should. F3 produces Mission Control. Fine.

However, F4 should be Spotlight, but it shows Launchpad. F5, which should activate voice command, lowers keyboard brightness and F6, which should be DND, is turning up keyboard brightness. The balance of them work as described.

They were working perfectly a week ago. I don’t recall making any changes in settings, but I must have done.

Is there anything I can do to get it back?!?

Thanks

The functions you describe are the default functions on mine. Not sure why it would have been different, or why it would have changed back.
Were you using a trial of some app that expired, or did you uninstall something?

I’ve installed and uninstalled a few things over the last week.

Picking back through the processes will be impossible. I could always do a restore from TM but I’d lose a lot of work in setting my Mac up :frowning:

So, to cut a VERY long story short, and having lost hours investigating, I have found the culprit.

I’m leaving this here just in case anyone else encounters the same issue: it was Karabiner Elements causing the problem.

1 Like

Ah. Very good.
If you want to continue using KE (like to create a Hyper key), you could remap the f keys back the way you want them within KE.

Thanks very much. I’ve actually used the HyperKey app, as it was only a few dollars but, critically, it made it really easy to have duality of purpose on the Caps lock key: quick tap: L CL. Hold: Hyperkey.

I’m sure KE could do that too, but for the hours it would have taken me to sort out, I’d rather pay a couple of bucks and support a developer!

1 Like

Interestingly I have KE installed and don’t experience any of the issues that you’ve noted.
I tried all the keys last night and they work as they should. ¯_(ツ)_/¯

1 Like

Yeah, F4 on mine, for instance, is LaunchPad, even though the Apple docs says it is spotlight.
I am using a non-Apple keyboard, just tried an Apple keyboard, and F4 is LaunchPad.

Here are the f keys from Apple’s website:

And here are the graphics on the keys on my keyboard:

And the on-screen keyboard viewer:

Well, interesting - on M1 Pro/Max MBPs, F4 is Spotlight, F5 is voice command. Screenshot from Apple’s site:
image

So Apple must have changed the keycodes for these keys when used as system control keys, rather than function keys on new M1s.

Looks like keyboards are a mixed bag, some with the old assignments, some with the new.
https://www.apple.com/us/search/keyboard?src=globalnav

Functiongate! Apple, why are you doing this???

(that’s satire, in case it’s not obvious)

2 Likes

Maybe you have different settings on the Function Keys tab. Those settings, combined with Mac System Settings_Keyboard can produce confusing results as far as what the Function Keys do with and without the fn key.

See my post above. Apple has changed the keyboards.

As OP noted, removing Karabiner-Elements fixed the issue. This is because KE emulates the old F key mapping, rather than the new one.

Keys that “work as they should” now means different things to different people.

Right. I was replying to aardy about Karabiner producing different results.