Issue with Samsung T5

Sooooo, I could use some tips and tricks here. :slight_smile:

I bought a Samsung T5 to use as a Time Machine Backup for my Macbook as I need an additional one. When setting it up and formatting it to AFPS something must have gone wrong. It seemed fine but when selecting it as a Time Machine Disk and selecting to encrypt it, it threw an error about not being able to be opened - and since then I haven’t found it in Finder.

If I try to do an Erase via Disk Utility, where I can find it, to reformat it again - I just get the following:

"Erasing “Samsung Portable SSD T5 Media” (disk2) and creating “Test”

Unmounting disk
Couldn’t open device.

Operation failed…"

Something seems to be really wrong with the whole disk, and I can’t find a good solution for how to get this back in working order.

Any tips?

Time Machine disk have to be formatted as HFS+

“Time Machine drives must be formatted in HFS+ (a file system released with Mac OS 8.1 in 1998 and found on every version of macOS since then). Time Machine uses the magic of hard links, a feature that HFS+ file systems have to catalog and keep track of which files in a backup make up the current version of an app, document, or directory.”


Doh, I just had in my mind that SSDs should be APFS.

Still not sure why I couldn’t manage to reformat the disk directly, but to get around the “can’t open disk” in Disk Utility I had to just remove the cable, restart the machine, and connect the disk again.

Then I could only get it to work by reformatting to ExFAT and back to HFS+.

Now it’s running it’s backup as intended.


Someone in the Forum wrote some months ago that formatting to Mac OS extended journaled, non encrypted, worked fine with Time Machine.

I just formatted a 1 TB T5 with APFS and it works fine. But I do not use it with Time Machine, I only backup manually on this SSD and also export Fotos to JPEG as a second backup for later uploading to Dropbox, now that my pro account has 2 TB to fill.

Side note: I also have a spinning external hard disk that I use with Time Machine and that is formatted as Mac OS extended journaled, encrypted. I use it for 9 months now and the encryption of the disk is still around 49 % completion. I do not know what this means, can it really be so slow to take months to finalize?

Since I have these issues with encrypted Time Machine Backups, I decided not to encrypt the T5.

Instead, I hide it in one of my rolled socks in the drawer and hope that any thieves don’t find it (and don’t read this forum :slight_smile: )


I ended up getting it to Case-Sensitive, Journaled, Encrypted before starting the Time Machine on it.

From previous Time Machine processes I’ve found that if I use an Encrypted format before starting Time Machine I avoid the process of Time Machine running encryption AFTER finishing the first backup - since it takes forever. So it might be that?