Karabiner elements, logitech K380 keyboard, forward delete

Hi Friends,
I recently bought a Logitech K380 external keyboard, which has worked fine except that there’s no way to forward-delete. It’s a known issue, and I eventually found a work-around through Karabiner elements, which lets me repurpose the useless (to me anyway) eject button on the upper right corner. It worked great on my old Air running Catalina. But when I updated to Monterey and a new Air running with an M1 chip, the remapping no longer works. The main difference I see is that there’s a lock on the lower left of the Karabiner icon on the new Air but not the old one. When I right-clicked, I saw that I didn’t have all permissions, but when I tried to change them, a popup window said: “The operation can’t be completed because you don’t have the necessary permission.” I reinstalled, just to be sure, and gave it the required input operations permission, but still no go. Any advice for working with Karabiner or another solution? It’s so frustrating not to be able to forward-delete! FWIW: I’m running MacOS 12.4 on a MacBook Air M1 chip 2020.

You don’t need a work-around for this. On the Logitech K380, the back button does the regular delete (“move to the left delete”), and the Delete button (top right corner above backspace) does forward delete (“move to the right delete”). Is that what you’re after?

I have the K380. Great multi-device bluetooth keyboard, and very easy to hook up to your phone and iPad as well as your Mac, so you can switch devices quickly!

Thanks. But unless I’m missing something obvious, mine doesn’t have a back button–it only has a delete. And a fn key. Come to think of it, I’ve never seen a back button on a Mac keyboard, which is why I always used fn+delete to forward space. It’s just that the K380 doesn’t allow for this.

Looks like your K380 has key caps selected and arranged for a Mac whereas the other K380 mentioned is likely one with key caps selected and arranged for a PC, as in the keyboard at this link.

1 Like

I’m using a Mac Studio on the latest version of macOS. And Karabiner is working for me.

I have mapped forward delete to shift-backspace and it works fine for me.

I too have the lock icon on the Karabiner icon, although I had never noticed this before. So I do not think this is the issue. I have had issues in the past using function keys with Karabiner. So maybe you could try mapping a different key or key combo to forward delete and see if that works.

Good luck, and I hope you get it sorted.

Thanks. Interesting about the lock not having an impact. Like I said, it doesn’t show up on my old Mac running Catalina. Maybe new security preferences. I’ll try a few more things and get back to this post if I discover anything. Thanks in the meantime!

Does the following provide any assistance?

Huh, I didn’t even know there were different versions of the K380! Sorry @Pommette, I didn’t realise that was the case. I have two K380s (different colours) and they both have the forward delete button. It’s weird though that the one I have, which I now assume is designed for a PC, has the functions needed for a Mac, and the Mac one doesn’t :thinking:

I assume you’ve been into your system preferences to try and update the consents for the app?

And one other thing …

… Control - D is forward delete on macOS.

1 Like

Thanks everyone. I ended up returning it, and am now in the market for something better. For now, I’m typing with the Air slightly open. Maybe I’ll test drive a mechanical keyboard! :slight_smile: Thanks for the moral and other support. Much appreciated.