LG UltraFine block sound

I have a problem where the build inn speakers of my 27" LG Ultrafine display take over the audio when using or screen sharing via Messages / Facetime.

No matter what I try the Build inn speakers take president over whatever input I select. Even using the headphone jack on my 15" MB Air doesn’t work. The speakers and microphone of the external display take over.

In macOS 14.5 Sonoma I cannot remove or block this connection or change the priority by dragging the preferred audio in-output to the top of the list.

I use AudioWrangler from Matthew Green to help with this most annoying MacOS feature oversight.

1 Like

Thanks, I will check it out!

I use SoundSource from Rogue Amoeba which would also likely achieve what you want

1 Like

@aardy SoundSource is amazing no question, and it allows per application defaults and many other features.

One consideration might be cost:

SoundSource. US$ 43.00 (from Rogue Amoeba)
AudioWrangler US$ 2.00 (from Apple Mac App Store)

PS - I love Rogue Amoeba products, and if you need the extra features SoundSource would get my vote, but for just routing audio away from your monitor, can’t go past $2.00.

So far I have had mixed success where the display just overruled all settings.

Will report later if this is a keeper or not.

Here is how I have mine configured, key thing is to “add new devices to the bottom of the device list”.

<tried to upload image, sadly got the the “Invalid region: region was not a valid DNS name.” error>