Mac App Store not updating?

Lately I often see App updates in the Mac App Store, but they don’t get installed (immediately) on my Mac (usually only after a couple of days).

For example, today I noticed that the Mac App Store lists Airmail 3.6.60 (from “2 days ago”) as the newest version, while I still have 3.6.58 installed on my Mac. However, the text on the button in the App Store is “Open”, not “Update”…

Additionally mas outdated does not list Airmail either (mas is a third party open source Mac App Store command line interface).

Anyone else noticing this?

How to fix it?

Happens to me all the time. When I notice it (usually when seeing there’s an update listed on MacUpdate) and I’m itchy to get the update because it’s a big one, I’ll delete the app and then download the latest version.

I’d found this checklist of things to try; it includes a Terminal command,but I’ve been too busy/lazy to try that one.

I had this issue recently after the Affinity apps went to 1.7. My issue got solved by going into the Mac AppStore-app, opening the page with Updates, then from the Store menu, I chose menu item Reload page.

This was on Mojave. Hope your issue can be as easily fixed too.

1 Like

No, that unfortunately does not work for me.

I’d rather not do that (in this case), as there’s a lot of configuration in Airmail (several accounts to set up).

Not in this case. MAS says you’re on the latest version when you’re not.

I still experience this issue, a lot (in particular with Day One, Spark, and Tweetbot).

While I do get the update button on the actual product page, nothing happens when I click that button…

As an aside…Airmail offers iCloud sync of settings/preferences

Mac App Store…

Unfortunately this is on a Mac mini that won’t even run Mojave.

It’s running High Sierra with the latest Supplemental Update (for that OS) installed.

The problem of not receiving notices that updates are available in Apple > App Store … has existed for me since I updated to Catalina. I’ve tried all the fixes that @Bowline pointed to. Looking at the full list of apps I’ve purchased by clicking my avatar on the home page of the Mac App Store does not indicate that anything has an Update. Only by navigating one by one to the app pages do I then see Update. Or, as mentioned, reading about or being told that something has been updated.

When I updated macOS to 10.15.1, suddenly Apple > App Store … said there were dozens of updates (!). But in the intervening weeks, no more notices – even though by chance I learned about updates.

Another Catalina annoyance apparently. Maybe 10.16 or perhaps waiting for 10.20 will set things right :rofl: