Mac Messages Text Getting Scrambled

Hello fellow Mac power users,

I’m posting here as a long shot but maybe someone on here can figure this issue I’ve been having with Messages out.

Essentially, when I’m typing, Messages seems like it’s trying to auto correct my typing. However, the corrections it’s making are random (e.g. moving parts of words to other places in the message, removing some things entirely, and even replacing some characters with punctuation. I saw auto-correct, but it doesn’t add the usual lines to indicate it’s made any sort of change.

I’ve scoured the internet, and actually found a post on Apple’s own support forums of others having this exact issue - scrambled messages on MacBook Pro - Apple Community but no one seems to have any sort of fix or explanation.

The issue only happens on Messages for Mac OS. I’ve had it happen on two separate Macs now. It originally started on my 2016 MBP, but it’s happening on my 14” M1 MBP too. Fearing that it was an OS issue, I actually set up my M1 from scratch, so it’s not some lingering OS cruft carried over from my past Macs. It’s been going on for a while now, so I don’t think the OS is the issue, but I’m running 12.5 Monterey currently.

I also thought it may be due to Grammarly being installed but I’ve since removed that as well.

At this point I’ve resorted to typing all my messages out in Drafts and then sending them to Messages because otherwise I run the risk of sending typos constantly.

Any suggestions are appreciated.

Did you try booting into safe mode as the linked article suggested?

Yes. This has been happening on two separate Macs with two completely separate OS installs.

Long shot, but if you haven’t, check the auto correct entries in the keyboard section of System Preferences? I’ve seen people prank someone by changing ordinary words into gibberish; maybe that database got corrupted somehow? Just a wild guess tho

Nope. I thought that as well, because I’m prolific text shortcut user and could have easily done something weird, but it’s random words. I even tried turning off auto-correct entirely, but it still happens, and only in Messages.

1 Like

So it continues to happen when you’re in safe mode? That definitely seems strange.

Maybe try a new user on the Mac?

This is an odd one and it seems to have been going on for a number of years as you mentioned. I hope you get it figured out!

My current annoyance with Messages is that I can switch from my main task to another Space where the Messages windows appears to be the focused or only window. The text input box appears to be waiting for my reply, focused with the usual cursor blinking. But when I dash off an answer without really looking, often nothing appears in the text box until I actually click in it. Then I have to retype my message. (Not as bad a problem as scrambled text entries, I’ll concede!)

I don’t suppose you’ve accidentally turned voice control on?

2 Likes

Nope. I don’t use voice control at all.

Yeah, the weird thing about this is I set up my new M1 Macbook pro entirely from scratch, so if a completely fresh install didn’t fix it, I don’t think a new user would solve it either.

1 Like

This same thing happens to me! I’m also experiencing the issue on an M1 MBP that I started from a clean install. I’ve never installed grammarly. My suspicion is it’s an OS issue… The drafts workaround does the trick, though.