Mac Safari pop-up blocker not working

I’ve set “Websites” prefs to Block and Notify all sites, but it doesn’t stop this one from appearing every time I go to this website. Are some just not blockable?

Also, is there a way to close such a popup with the keyboard, instead of finding and clicking the tiny X with my trackpad? Cmd W closes the tab, and not just the popup.

I can’t get a popup when I need one! Maybe the Escape key might work. There should be some way to do it from the keyboard.

FYI, I went to, logged in, and can’t get any pop-ups at all even if I disable pop-up blocking and content blockers. Maybe you have been specially selected! :smile:

This is a problem of naming.

What Safari is offering to block is new Safari windows (or tabs) which are spawned by web pages. This used to be a huge scourge on the web, especially with pop-up ads.

Then what happened is that people who design websites figured out that they could no longer use pop-up windows, because people hated them, and instead of saying “Well, since people hated that, we shouldn’t do anything like that” they said “How can we achieve effectively the same thing in a way that will work-around the fact that most browsers block pop-up windows/tabs?”

Then came this disgusting creation that you are seeing, which I believe is technically called a “JavaScript overlay”.

It’s not a separate page/window/tab, it is in the same page/window/tab that you are viewing, so you can’t use ⌘W to close it, and most of them aren’t coded well enough to respond to the ESC key (which is entirely possible but apparently none of them care about the user experience enough to add it in).

Because this is done via JavaScript and the page you are already on, it is much more difficult to block, especially because there are a wide variety of ways of generating one of these pages.

So now (almost) every dang website out there uses them to try to get you to sign up for their newsletter or whatever the crap is that they want to get you to do, when all you want to do is read the page that you are on.

In Safari, the best response to seeing one of these is to press R (command+shift+R) to enter Safari’s “Reader” mode, which will get rid of all that crap and nonsense.

JavaScript is an incredibly powerful tool. Unfortunately, IMO it is used (or seems to be used) for annoyance as often as benefit. (The problem is that benefit probably goes unnoticed more often and annoyance, by definition, is something you’d notice…)


I think I got it because I was logged on, and it’s an “up-sell” for account holders. Thanks!

Thanks for explaining. You’d think the Safari setting would more clear about what it does. Instead, it just looks like an Apple feature that doesn’t actually work. (My career was in communications, so things like this really bug me!)


I logged on as well and saw nothing. The message looks like you got the up-sell because it was your birthday. Happy Birthday :birthday: ¡