Mac won't Paste Rich Text anymore

Hi techies,
For the past week or so, my “Paste” setting has been set to always paste plain text. But sometimes I actually want the “rich” text from the original to be pasted.
I think I did something but can’t remember what setting I might have changed.

In the past, I have set CMD-C and CMD-X to copy/cut and then paste the rich text. When I wanted plain text, I used my Launchbar clipboard instead which I had set to always paste plain text.

I’ve been playing around with Keyboard Maestro (using David Sparks keystrokes for window management, and then migrating my small cache of TextExpander snippets to Keyboard Maestro) and I wonder if I’ve somehow changed a setting in KM that has caused me to lose the option of pasting Rich Text.

Does anyone have ideas about where I can look to try to return to having the default behavior be to paste the rich/original text?

Don’t hesitate to ask more questions.

Check System Preferences > Keyboard > Shortcuts > App Shortcuts to make sure you haven’t overridden the default ⌘V setting to do something else – perhaps configuring it to “Paste and Match Style”, for example.

It’s also possible to change the Global Preferences config file – but that’s not something simple to do and you would remember if you had done that.

Most likely you’ve configured ⌘V in TextExpander or Keyboard Maestro to do something different than what you expected. Open the KM editor, select the “All” group, and in the Macros panel (in the middle) look through the list of macro triggers to see if you find ⌘V anywhere. If there’s a macro with that trigger, it could be the culprit.


Also, many multiple clipboards, like Copy 'Em Paste and Pastebot, have that as a selectable option for all copied text (converting to plaintext is a setting I keep on), so if you are using a multiple clipboard in addition to KM check its settings.

1 Like

I’m still troubleshooting this problem, but had a break-through today. I decided to start turning off apps that might be interfering. Sure enough, as soon as I quit the Copied app, then my Paste Rich Text worked.

In the past, I’ve definitely had Keyboard Maestro and Copied (and TextExpander, for that matter) all involved at the same time and I was still able to Paste Rich Text, so there’s something that changed. But at least I have a workaround now for those times when I really need to be able to Paste Rich Text as it was formatted in the original document.

Copied has a shortcut to flip the clipboard into Plain Text Mode ^⇧T, and it’s easy to inadvertently activate that.