MacBook Air M2 losing battery when sleeping

I have a MacBook Air M2 13’. I don’t use it often, so it’s usually in sleep mode.

But then when I do have to use it, the battery is often completely low, even though I charged it in full before sleeping it last time.

Does anyone else experience that sleep mode runs the battery down?

Yes, this happens to me too. If I know I won’t be using the Mac for more than 12 hours, I shut it down instead of putting it to sleep.

1 Like

I guess the point is SLEEP ≠ DEAD. The Mac will wake up for maintenance and background purposes (fetching mail, for instance) while sleeping. You need to shut it off if you want no battery drain, but it will run a long time sleeping. I used a MBP several days a week and just let it sleep over the weekends with no problems. This is an Intel MBP – they all behave the same. iPads, too.


Make sure Enable Power Nap and Wake for Network Access are turned off.


The Apple Silicons shouldn’t be draining that fast when sleeping. Here’s what eight hours of lid closed should roughly look like in Activity Monitor.

Screenshot 2024-05-04 at 12.03.35 PM

Possible things to try:

  • particular software you’re running that doesn’t play nice
  • some system setting malfunctioning (screen time and weird wifi used to do this for some people)
  • wired network or USB activating it when it shouldn’t
  • needs an SMC reset
1 Like

That was either an Intel thing or they removed it from settings. It is not an option on my M1 MBP. Might be able to change it in Console?


Apple Silicon Mac’s don’t sleep like Intel Macs did.

Think of them more like the way an iPad runs, but macOS doesn’t have the ability to “control” what apps can do and whether they can run in the background.

So the battery will be reduced if apps are running when you close the lid.

1 Like

That may be. In Ventura, they’re hidden behind a small Options button at the very bottom right of the battery settings.

1 Like

I don’t understand it, but this M1 Mac Studio had this thing where out of the box where it would get really warm when it “slept”. It goes into some sort of sleep state where the fan turns off, and hence the Mac got really warm to the touch. Apple told me it should not do this, but they couldn’t find a problem either. Not everyone with an M1 Studio had this issue. I had to go into Console to turn off power nap, since it was removed from settings. Now, my fan turns off and the Mac doesn’t get warm to the touch. So it does go into some sort of sleep state.

I had to look up my notes, yes you can disable Power nap on an M series Mac, but you have to do it through Console.

sudo pmset -a powernap 0 womp 0


Okay that’s not my experience with the MB Air M2. I charge it in full. Sleep it and a few days it’s most definitely down to half a batery

I don’t close the lid on it. I rarely do that, only when I’m transporting it do I close the lid.

What’s an SMC reset?

I never close the lid on it. Only when transporting it. But I should probably go in and remove apps I don’t require anymore

I don’t understand. Do you think this issue with my Mac draining battery in sleep mode could be fixed by turning off Power Nap mode?

System Managemen Controller. It would be something to try if you’d exhausted other options. But I misspoke: on an Apple Silicon Mac, doing a complete shut down and power back on is the equivalent of resetting the SMC on Intel.

One thing to try would be closing the lid to see if it fixes the issue. I’m not saying you’re doing it wrong, but that would help narrow down what’s happening.

Probably not, I was just addressing what someone else posted. Something you could try though. It’s not like Power Nap is important, unless you really need middle of the night Time Machine backups. :slight_smile:

Allison Sheridan from the Nosillacast podcast has been experiencing a similar behavior on her M1 Max MacbookPro. She basically is on a year-long crusade to find the root cause for this battery drain.

She has documented her experiences on her podcast and her blog - here is a list of the blog posts involved, including extensive support experiences with Apple and a lot of debugging - and even buying a new MacBook Air M2 to get rid of the issue.

Her most recent post:

She was able to finally get it to stop. She still is not 100% sure what was going on, but one thing that may or may not be of interest:

For my next test, I needed to let iCloud finish downloading all of my photos. As I’ve mentioned, this is the Mac on which I keep all of my full-resolution photos. I was taught years ago by an Apple Senior Advisor that the fastest way to get them down is to start from scratch and download originals. If you let it download optimized images first, and then change to full-resolution, iCloud has to check every single photo one at a time to see if it’s full resolution. Back when I had around 75K photos, it would take 3.5 weeks to bring them down after optimized were already there. Apple said that was normal and to be expected. I flipped the switch to download full-resolution images, plugged it into power, and changed the battery setting to force it to stay awake. (…) The entire download took about a day and a half and it was ready to run another sleep test. I started the test at 8:36 AM and finished at 6:16, so just under 10 hours, and in that time span it lost, drumroll please … 0%. It stayed solid at 100% for 10 hours.

These days, all the syncing going on is a challenge…

I have a MacBook Air M2, too. Fortunately, it does not really drain its battery when sleeping. I can have it sitting there for days without significant battery drain when sleeping.


Thanks! and sorry for the late reply. This is what I got from the Terminal running the command:

System-wide power settings:
Currently in use:
standby 1
Sleep On Power Button 1
hibernatefile /var/vm/sleepimage
powernap 1
networkoversleep 0
disksleep 10
sleep 1 (sleep prevented by nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, nsurlsessiond, cloudd, cloudd, cloudd, cloudd, powerd, coreaudiod, Finder)
hibernatemode 3
ttyskeepawake 1
displaysleep 2
tcpkeepalive 1
lowpowermode 0
womp 0