MacBook Pro start up issue

My daughter’s MBP 13” - late 2017, running High Sierra or Mojave - won’t boot; the “thermometer” gets stuck at the end.

I have tried resetting the PRAM, safe boot and starting up from an external drive. Same problem, although the boot from external drive gets stuck at about the 3/4 point, not the very end.

The school’s IT people didn’t have any better luck.

I have a Genius Bar appointment, but not till Thursday afternoon so, if there are any other ideas, they would be much appreciated.

“Best” news is that her schoolwork is stored on the computer, not any of the cloud or back up services I, or the school, has made available.

How about SMC reset? Not sure why it would help, but it did fix an issue I was having this week.
It took me a while to get it right: turn off (not restart), then hold shift-control-opton-power (on my MBP version) for 20s. The computer doesn’t start, telling you that you did it right. Then start as normal.

1 Like

Thanks, I shall give that a try.

I did also try the SMC reset according to the 2 options described here, but the computer just continued booting.

I have had little luck with the SMC reset keyboard command on MacBooks and end up opening the bottom shel and disconnect the batterie. Press the power button for 5 seconds etc.

Alternatively did you try to boot into the recovery partition and reinstall Mac OS ?

My mistake was always turning on then pressing the combo. If you press the combo first then power it seems to do the trick. But there’s no way to tell afaik. Could be a placebo/coincidence!

Oh yes, tried the boot into recovery partition without success too. Unfortunately, with this model MBP, I don’t think opening it up and disconnecting the battery is an option.

Hmm. With the number of variations I tried, I am not sure now whether this was one I tried. Will give it a go tonight when I try your combination.

Have them boot into a Triage OS first to see if data recovery is an option.

She is most likely looking at an Erase and Install of the Operating System. There is also a test that checks the Firmware of the SSD, but the cure wipes the SSD.

Did you try the safe boot by holding down the shift key during startup?

Yes. It gets about 80% or so along the thermometer bar, then hangs.

Have you tried booting to diagnostic mode? CMD+D i think.

It’ll check your memory and your SSD.

Thanks. Just hold down “D”, then power up.

Ran this, reported that No issues found. Code ADP000.

Genius Bar tomorrow.

1 Like

Is the disk formatted APFS? And if so, was it upgraded or clean formatted?
Over the past year this 3/4 boot issue has popped up with regularity in forums and most of them seem APFS upgrade related. Clean formatted APFS seems not to have these issues.

Maybe it’s the cause here too?

1 Like

I don’t think I know what the difference between clean formatted and not is. In any event, I don’t know as the school’s IT department imaged the disk to load the school software on to it (that apparently means something to them).

The Apple Genius hopes it is a case of the storage being too full. 512Gb and in use for 18 months study??? Running some diagnostic that was going to take 2 hours.

If not, will require a new logic board.

I am wondering if there is some way to get the data off the storage (SSD) or detach the SSD for use in an external enclosure. (Late 2017 MacBook Pro).

After all the things you have tried, this feels like a hardware problem (graphics module) to me. 2017 is not old for a Mac so if it indeed is hardware Apple might replace for free (they did with my 4yr old mac book pro)

Yes you can use target disk mode to an other Mac with USB C

1 Like

Oh well, Genius decided the logic board needed to be replaced.

Although we are coming up on the computer’s second anniversary, Apple volunteered to do the job at no cost under Consumer Law warranty.

Didn’t get the chance to try to get the data off first.

1 Like