macOS 12.4 broke Universal Control for some users - Update the iPad to 15.5 to fix it

I spent the past hour manically pushing my cursor against the side of my display and trying various eldritch troubleshooting steps before I found this page, where several other users are reporting that updating to macOS 12.4 made Universal Control stop working for them.

Hopefully, if anyone here runs into the same trouble, they’ll see this thread before they spend an hour manically pushing their cursor against the side of their displays.

(Currently updating the iPad to 15.5. Maybe that’ll fix it — I’ll report back!)

Seriously, though: the dark side of the “magical” experiences Apple’s known for is when they break.

If I were a wizard whose magic stopped working for some reason, I think this is what it’d feel like.

I know you have tried this, but it broke for me and I rebooted my iPad and it worked again.

Oh, actually maybe it was the iOS update that was rebooting it? :joy:

1 Like

That’s one reason why a lot of pros have waited until now to upgrade from Big Sur to Monterey.


Hope this helps …

I’m still waiting :grin:

(20 characters)

@beck Yeah, I rebooted the iPad and the Mac, both, twice, at the same time, and then also iteratively.

Among other incantations, prayers, sacrifices, and the like.

@WayneG I hear ya, but Universal Control is a feature of Monterey, so it would’ve been hard to use it to begin with in Big Sur!

Updating the iPad to 15.5 fixed the issue. I didn’t realize there was an update out for both when I began this process. :person_shrugging:

@MevetS where were you two hours ago?!

Well … you could have reached the forum! :slight_smile:

And while it may have made sense for the two OS’s to be in sync while it was in ‘beta’, that seems an unnecessary complication now. Apple should make it such that being on the top level release, i.e. 12.x and 15.y, are sufficient.

1 Like

Just for posterity: I actually did do this, and the top results were all about how wonderful Universal Control was, so I figured it wasn’t covered here before.

Hopefully my nice verbose subject line catches the next poor victim’s eye before they hit publish!


Alas, I am one of these poor saps. However, the fix didn’t fix it. So, if there are any other suggestions I’m open to suggestions. I can add my iPad as additional screen, handoff is working. However, this one little feature, that I really enjoy doesn’t want to come back.

Did you check System Preferences > Displays and then click on the "Add Display"drop down on the lower left and select your iPad to “Link Keyboard and Mouse”? I’ve found that my iPad will get unselected from time to time.

No, but I figured out what happened. I had to restart my Mac quite a few times until it recognized the need for an update. So, my iPad was at the 15.5 but my Mac was not yet at 12.4 even though I thought it was and I know I checked for updates. But, whatever. It’s solved.


I upgraded from MacOS and now Universal control works between my Mac Pro and iMac.

Very very nice.

1 Like

And I spoke too soon… now it works for an hour or so then stop working for an hour and goes back and forth intermittently. Very odd.

Last time I updated macOS it worked for an hour and then never again.

** What sort of background process might get reset with an OS update but then go back to its prior state and prevent Universal Control from working within a short time?

If you have a VPN running it will interfere with Universal Control (and Airdrop). At least it does for me with Surf Shark.

Interesting point. I don’t have a VPN but for sure I must have some other software that interferes - no clue which app it is though.

The plot thickens re: Universal control

For 12 days Universal Control did not work at all no matter how I configured Display Preferences.

Then today this icon appeared in my Menu Bar. If I activate “Link keyboard and mouse” to my 2nd computer - instantly Universal Control works between my Mac Pro and my iMac.

The question is - what is this icon? Is it simply the build-in MacOS preferences panel? If so why did it appear now in my menu bar? And why does it have a “Link” option that Display Preferences does not have?

1 Like

I think it is Displays.

Hover the pointer over the icon in the menu bar and it should show a tooltip saying what it is.

Nothing shows when I hover over it in the Menu Bar

But when I hover over it in Bartender it does say Display

More interestingly - when I go to the Control Panel icon in the menu bar I can display this under Display:

Note the version in Control Panel does not give me the option to “Link keyboard and mouse.”

For the last hour or so the icon in the menu bar has intermittently appeared and disappeared; when it appears, Universal Control works. When it disappears, Universal Control no longer works.

Why does this happen? How do I make the “Linked keyboard/mouse” stay permanently?