MacOS Big Sur Issues


I am currently trying to update mbp2018 with t2 to the public beta but it always says can’t do it. I added some images of the error and part of the log. Any ideas? I already booted on recovery and check that I have higher security on the security section. Any ideas? What I can do?

Not sure if it’s linked but past two updates on the developer preview wouldn’t install, seemed like it was but didn’t actually complete. Then would prompt update again.

Work around was boot holding down option key and select install disk from there and it worked.

Hopefully it helps?

I created a usb bootable… did ask for some update missing… I tried to update and some error occurred no details. No luck.

Just had a look around the error codes and found someone with a similar problem on a different software update on macrumours. The advice from Apple to fix it was:

I just received my 6th call from Apple Support and this one did the trick. Finally got the update and no more error.

All Macs with a T2 chip need to shut down, once fully shut down, hold the power button for about 15 seconds (you’ll see the Apple logo appear and then disappear and go back into a shut down state), once that’s finished, turn it back on, log in and do the update. You’re good to go from there.

Can’t say It will work but it shouldn’t do any harm to try?

Did not worked. I saw something about the re-install bridgeos but it seems very complicated …

Yeah seems like it could work but carries a bit more risk. Personally i would be reluctant unless you really need to update, next version will likely come in next week - see if that one works?

I would wait and see.