macOS garbles email newsletters

Occasionally (but not always) on macOS will garble a received email newsletter. This usually involves Mailchimp newsletters. Viewing the same newsletter in a browser-based email client or even iOS works fine. Has anyone else had this problem?

I can’t recall having this issue. Is this happening in Mojave or a different version?

Did you change the settings to disable HTML formatted emails?

How to remove HTML from all messages in Mac Mail?

If you prefer to read your mail messages in plain text with no HTML design, effects, and attached images, you can go to Mail: Preferences > the Viewing tab > turn off the Display Remote Images In HTML Messages option.

This will trim the remote images from your messages but will not remove the HTML code or the images inserted in them.

To do this, you should:

close Mail;
start Terminal;
execute the following command in Terminal:
defaults write PreferPlainText -bool TRUE

To reverse this and enable HTML in your emails again, simply execute this command in Terminal:

defaults write PreferPlainText -bool FALSE

Currently, but happened with HS too, both during public beta and regular release.

No, I’m not trying to strip the formatting; in fact, I prefer the HTML look for newsletters. errantly strips, and then garbles, the formatting for me!

Here’s another example from this morning. Again, I’m not asking to change the formatting.


For reference, this is the exact same email, at the same time, viewed in on my iPhone.


Did you try to enable HTML via Terminal?
Try it just in case it has been turned off by something else.

In case Safari isn’t your default web browser. Open that one and verify that the html formatting is working. Of course run all updates.

If all else fails, reinstall the macOS.

I’ve had similar issues with MailChimp and a few other similar services. I assumed it was the service and not I reported the issue to the sender of the email. I no receive those email newsletters, so I don’t know if it’s still an issue.