macOS Mojave time changes

I have an iMac running macOS Mojave.

A couple of times a day the time changes back to the 5th December 2013, 11 p.m.
When I go to System Preferences -> Date and Time and unlock the pane with my administrator password the time gets corrected.

I have tried to set the time zone both manually and automatic and tried all of the three Apple time servers.
Does anyone have an idea how to fix that?

Are you running something like Little Snitch? Maybe something is blocking the connection to the time server.

No, I’m not. Unlocking the pane is probably triggering a new synchronization and that works fine.

You don’t say which iMac you have. Check these support articles and choose the correct one for your model:

Thanks for the links, I have reset the NVRAM for now. I’ll report back if that helped.

1 Like

That’s definitely weird. Hopefully the NVRAM reset will help.

It would be possible to periodically “set” the time using launchd but it’s really not ideal, especially since Apple has removed the ntp tools, which is what you would have used in the past to manually fix this.

That said, you can install them via brew install ntp if necessary.

If the NVRAM doesn’t fix it and you want to try a script, drop me a note. I still have one from a few years ago when Mac OS X had an issue with time “drifting” that I’d be glad to send your way.

Is the time set automatically in settings? (on location basis?)
Or do you manually put the time in?

If it is automatic it could be the time server has an error?
Or your gps signal is having issues?

But: if you have the time set automatically, what happens when you put a manual time in. Does it still change several times per day?

So the NVRAM reset didn’t help.

I have tried all three of Apples time servers and disabled automatic time but the date still resets about once or twice a day.

I don’t really want to set up an launchd script to fix the symptoms (yet). Maybe it’s some application going rogue? But the app would probably need accessibility permissions(?)

For now I have removed all apps there besides Alfred and Spectacle.

I’m really not sure, but if I had to guess, I’d say it was something that was accessing the Unix-level rather than the accessibility stuff, but that’s just a guess.

I even tried searching but everything seemed to be about iOS not macOS.