macOS scroll bar settings

For a while now macOS keeps adjusting my scroll bar settings to show “Always” after rebooting the system (like the image shows). I only want them to appear when scrolling. Is this a common issue and is there a solution? I had this in Big Sur and it’s still present in Monterey.

Sorry, but this tenacious grip on the “Always” setting is my preference. Is someone in Cupertino reading my mind? :slightly_smiling_face:

In the old days I’d say your pref file got marked Read-Only but that doesn’t seem applicable these days.

I don’t have a fix for you but thank you for this which made me realize I probably do want this set to always so I can tell where I am in a long page or article. Wish I could do this on the iPhone


Well, it’s not something that I’ve heard widespread reports about, but it seems common for you…

As for a solution, what I would try is entering these three lines in Terminal:

defaults delete NSGlobalDomain AppleShowScrollBars

defaults write NSGlobalDomain AppleShowScrollBars -string “WhenScrolling"

defaults read NSGlobalDomain AppleShowScrollBars

Note: you may get an error like this one after the defaults delete command:

2021-11-07 03:48:25.345 defaults[18686:5176631]
Domain (kCFPreferencesAnyApplication) not found.
Defaults have not been changed.

which you can ignore. All that means is that we tried to delete something that did not exist.

After the last command, you should get a response of:


Try rebooting again after those commands, and see if the setting “sticks”.

(If it doesn’t, I have another option.)

1 Like

Thanks! I will try that.

1 Like