Mail rule to forward/redirect isn't working. Anyone successful with forwarding?

I’ve got this Mail rule:
Rules-2
When I receive mail from a number of wineries, it is supposed to resend (I’m using Redirect but have also tried it with Forward) it to my wife, then flag it and move to my Wine mailbox.

What it does is flag the message and move it to the Wine mailbox. It doesn’t appear to even attempt to send the message. To make matters more confusing, when I save the rule by pressing OK the actions get sorted, putting Move Message first. So something really hokey is going on. I’ve tried deleting the rule and reentering it to no avail.

So is anyone here using a rule to redirect/forward messages successfully? If so could you post what the rule looks like. Perhaps I just need a different approach. A web search brought up nothing useful – people reporting issues with this never seemed to get it resolved. Hopefully there is a Power User that has gotten this automation feature to work.

I do this all the time but I use server-side rules (gmail on gsuite for business) so my Mac doesn’t need to be on for the forwarding to occur.

Ditto but with fastmail.

OK, after a lot of fussing around I discovered the bug in that “Redirect Message” or “Forward Message” only work as an action if there are no other actions. So it works if I use two rules:
Screenshot_9_7_18__1_20_PM-2
followed by:
Screenshot_9_7_18__1_22_PM

Curiously, Apple’s example of use has only one action.

It’s interesting that yours is working. I have only asked Mail to forward a message based on conditions and it doesn’t work at all. I’m trying the server-based rules on the icloud.com site now to see if this helps.

The plot thickens…

1 Like

Over two and half years later the rule to forward mails still doesn’t work! That’s pretty shoddy from Apple. Hope it gets fixed soon.

Fixed? It isn’t obvious it ever worked to begin with! Anyway, my workaround continues to function just fine.

1 Like

Thanks for chiming in, @tomalmy. I’m sorry but I’m not sure I understand the workaround you are referring to. My rule only has one action (Forward Message) but doesn’t seem to work. Can you suggest any changes?

I ended up using Redirect Message rather than Forward Message. Try that.

1 Like

Unfortunately that doesn’t seem to work for me either :confused: Thanks anyways @tomalmy! Please do let me know if you find another workaround.