MBP Apps freeze when opening docs!

Overall Issue
Last week, my apps began freezing up when opening documents. This occurs with both Apple apps and 3rd party apps. It seems to happen with apps that access documents from my HD. For example, I’m able to browse in Safari without problems. Double clicking on a pdf, jpg or other file to open it causes the app to freeze. System Settings also freezes when attempting certain tasks.

I give some detail of specific instances towards the end of this post.

Here’s what I’m looking for in terms of help:

  • Has anyone experienced this and does anyone have any idea the cause or a solution (not listed below)(to the problem?
  • I talk about creating a new Volume on my HD below and “migrating” to it. Does this seem like a reasonable next step and is there an easier way to do this than what I’ve listed?
  • Any other help is greatly appreciated. Thanks!!

Here’s what I’ve tried:

  • Reinstalling the macOS (Sonoma 14.4.1). The problems were the same.
  • Booting up in Safe Mode. Still, the problems occurred.
  • Creating a Test user and copying a variety of files to it from my primary user. I also downloaded 3rd party apps that had exhibited the problems. It appeared that things worked normally in the Test user.

I’ve spent hours talking with Apple Senior Advisors. It was finally suggested that I create a new Volume on my hard drive and install a new copy of the macOS and that I then install the apps and copy some files in the new volume as I did with the Test user account.

It appears that everything works normally in this new volume, so it seems I now need to “migrate” to this new volume (although Apple said not to use the Migration Assistant because whatever it is that is causing the problem could be copied to the new volume).

Unfortunately, I envision this will entail a lot of work and a tremendous amount of time, which I don’t have. Is there a simply way for me to move all of my files to the new volume I created? I assume that the process would entail these steps:

  • Sign out of my cloud services on my primary drive (iCould Drive, Dropbox, Google Drive, etc.) and then sign in to those services on the new volume and eventually all of my files will synced/download from the cloud. (Currently I have only 180 GB free on my HD and my iCloud Drive contains 658 GB.)
  • Download all of my 3rd party apps and set them all up according to how I use each one.
  • Is there anything else I’ll need to do? Am I overlooking anything?

Here is a description of the typical problems I am having:

I first encountered the problem with pdf docs, which I have set to open in PDFPen Pro. Double Clicking on a pdf doc (with PDFPen Pro not open), the PDFPen Pro app appears in the doc, but the menu bar still shows Finder and not the PDFPen Pro menus. And, the pdf doc itself does not open. One time I waited to see if the doc would eventually open, and after 10 minutes (I timed it) the doc finally opened. But when I tried to do anything with the app after it opened, for example I typed Command-S to save, I got the spinning beach ball. If I waited several minutes, the app would eventually ‘unfreeze.’

I’ve tried opening pdf docs with the Preview app and have basically the same issues as above.

In the Photos app, I opened the app and selected a photo I wanted to export. After selecting the Export command, the window opened where I select how to format the exported photo. Clicking “Export” again should open a window where I can select the destination for the exported file, but at this stage I just get the spinning beach ball. If I wait for several minutes, the spinning ball goes away, but without exporting the photo. I tried this operation repeatedly and after about ten attempts, it finally exported a photo normally, but in subsequent attempts the problem persisted.

If I double click on a photo on my desktop expecting it to open in Preview, I have the same problem as when I double click on a pdf on my desktop — the Preview app icon appears in the dock, but nothing happens and the Preview menus do not appear in the menu bar. If I wait several minutes, the photo eventually opens.

This behavior is the basically the same for any app for which I double click on a file to open (e.g., videos in QuickTime, photos in Photos app, pdfs, etc.)

MS Word behaves slightly differently. If I double click on a Word doc to open it, a window opens that says Microsoft Word at the top with the message “Processing…” and some sort of activity bar moving back an forth. I haven’t waited to see if it will eventually stop but I can close this window and the normal MS Word initial window opens allowing me to create a document, open a recent document, etc. If I create a new document, when I try to save it, I get the spinning. ball.

When the above things happen, Activity Monitor lists the respective app as “not responding.”

Another Issue – Related?
I don’t know if the following issue is related because it began several months ago while the above problems just started last week. Several months ago my MBP’s screen stopped going to sleep when not being used (when connected to power). I checked to ensure that settings were set to turn the display off when inactive for 10 minutes. I also deleted the Amphetamine App & Caffeine app, but still, the screen does not sleep.

Thanks to anyone who can assist me with this!

I’d start by running a scan with the free version of Malwarebytes just to make sure your machine hasn’t been infected with something

That’s a doozy of a problem!

I might have experienced something related, though my problem seems to be mostly limited to Finder. Sporadically, it will just stop responding entirely. I usually figure this out because my Finder windows won’t come to the foreground. Activity Monitor reports it as “not responding”. I must admit that I haven’t waited 10 minutes (more like 1-2) to see if it starts responding again. I just open up a terminal window and kill off Finder so it restarts.

I vaguely remember having a “freeze” problem with Preview, too, upon switching to it. Not with opening a new document, but if something’s already open I cannot interact with it (scroll, click, etc.). Very annoying, but it isn’t consistent enough for me to waste time trying to troubleshoot.

This is on Sonoma 14.4.1 on a Mac Studio.

I’m glad everything is working on the new volume. I had to do this kind of migration once. Mind you, this was before the cloud came to hold all of our data, but I found the easiest way to move my data was to dump it all onto an external drive, reboot into the new account, and move it back. Very straightforward. The trickier thing was figuring out what software configurations were so time-consuming that I was willing to risk bringing over their supporting files instead of setting them up from scratch. Obviously, something in the system seems to be screwed up, so you want to limit this. But some apps, like Hazel, might take a long time set up again. So you have to figure out the trade-off.

(Note: I believe Hazel now has an export/import function.)

Once I did that, and figured out how I might move various preferences/settings, I just slowly began to install the apps I needed them. I had a list of apps from the prior account in a text file. I used the same text file to record each app as I installed it (and if I moved over any prefs/settings files).

As I recall, it wasn’t as onerous as I expected. I did it over the course of a week, “fixing” things as I came across them.

If you installed the 3rd party apps inso that all users can run them, then you won’t have to reinstall apps. Most of your time will be setting up the apps so they are customized to you.

If I had to do this now, I would sign out of any cloud service (in my case, that’s just iCloud because I prefer to keep things simple). If asked, I would choose to keep a copy of my data (just as a backup in case of disaster during this move). Then I would copy all of the data to an external drive. Log into the new account and copy the data over.

Then I would log into the various cloud services and let them figure out what’s in sync and what isn’t. In the case of iCloud, this is likely to take a few days (especially for Photos). But this way gives me immediate access to all of my files, even if the cloud is unsure about them!

(I suppose a smart thing would be to see if these cloud services have a preferred way of migrating to a new account/computer.)

On the other hand, I would let Mail download all of my email.

I would set up a new drive as a Time Machine drive.

Finally, once all of the cloud syncing services are happy, I would check Backblaze’s help to figure out how I should start to back up the “new” system. They do some wizardry to tie your backups to your computer, so you want to make sure you do this correctly. In this case, I would want to give up the old backup and start a new one. It will take a while before that backup is complete. But it’s only the Library folder that I don’t want to continue using, so maybe they have some way to have the new account inherit everything except the old Library folder.

2 Likes

Good idea to check for malware. MalwareBytes said mine was clean.

Thanks so much! Some very good tips there and I appreciate being able to benefit from your experience! I did run Malwarebytes right away it like for you, it gave me a clean bill of health. I’d forgotten about the challenge with Backblaze, so I’ll follow your suggestion there. I guess when it comes down to it, I just need to get started!!

Is there any chance this is related to the files being “ejected” from local storage by iCloud, necessitating a file download operation when you double-click to open? I try to keep most of my files downloaded, but have experienced what appears to be a hang when I double click on files in the Finder that macOS has decided to offload from local storage. Just a thought?

1 Like

The other thing that’s coming to mind is a hardware issue. It seems like you’re really struggling with I/O based tasks. Browsing in Safari does incur some I/O but nowhere near the same as playing with local files. Have you run any hardware diagnostics, especially for the drive?