MBP M3, iPad M1

Ok, I am running a relatively new MBP M3 (14 inch, 18gb Ram, Sonoma 14.4.1) and my iPad Pro M1 (up to date iPadOS). I also have a Samsung external monitor (it’s about 6-7 years old) and have used the iPad in sidecar mode as a 3rd monitor from time to time. I’ve tried to set that up today and can’t seem to get it to recognize the iPad.

Restarted, switched wifi networks, etc. Wondering if I’m doing something wrong here as it’s worked fine in the past but I’ve only had the computer for just over a week, so last week it worked Tuesday-Friday and today was the first time I’ve tried to run sidecar since.

I’m guessing it’s something stupid, but thought I’d check the wisdom of y’all regardless.


I also had a lot of issues this week with universal control. I rebooted the iPad and Mac a couple of times, and eventually, it recognized it. I think there are some bugs in the latest MacOS and iPadOS preventing it from working all the time.

Ok, I won’t worry much about it for a few days. I mainly wanted to run my calendar on the iPad and be able to make adjustments using the mouse and keyboard, but ended up spending entirely to much time fiddling with it.