Meeting.ics won’t download

On both my iPad and iPhone, from the appointments often won’t download. I just press and press on it and nothing happens. I’m able to do it on my mac, but often times I’m using only my iPad. Couldn’t find any solutions after Google searching. Any thoughts?


Is this a general problem, or mainly from a certain source?

I don’t know if this is the case, but this happens a lot with emails sent from Exchange to a non-Exchange provider (I’ve seen it with Fastmail and Gmail). The attachments become impossible to open.

Most of my invites come from Exchange to Exchange (we’re all on the same server). I feel like I’ve had this problem for at least 2 years, but it’s becoming more common now.

I had it a time ago, that I couldn’t open the .ics Files from one source, when I took a seminar.
It turned out then, that the App they used to produce the .ics was not working 100% acc. to the rules set down for those file.
Unfortunately I have no idea how the problem was solved, but from one day on, it just worked. They seems to have changed something (maybe the app).
Maybe it is a similar issue here?

Thanks. Hopefully the same happens here. These are all likely made by someone creating an invitation in Outlook, most likely the Windows desktop application.