Messages on Mac not downloading images (or video)

A couple of days ago I did a clean install of my 2019 Intel MacBook Pro. I use Messages on my Mac a lot, and I’ve rarely had problems since Apple provided this service, but since my clean install it will not download images or video. I just see the file symbol and if I want to see the image I have to click the download button (which also opens preview, rather than just loading the image in the conservation). Since I get a lot of photos sent to me, it’s rendered the Messages app somewhat useless right now and it’s very irritating.

Has anyone experienced this before, and if so what was the fix?

I’ve googled the problem but most the advice either doesn’t apply (it’s for iOS even though I’m looking for MacOS help), or hasn’t fixed the problem. E.g. Apple doesn’t even have a page for what to do if no images are downloading at all. I’ve tried deleting the attachments folder in Library>Messages>Attachments as some users have suggested that is sometimes the source of the problem, but it’s not fixed the issue.

(I thought a clean install means you get to start with no problems, not find new ones :upside_down_face:)

I’ve not had that exact problem. When I have a problem I disable “Enable Messages in iCloud” then turn it back on.

Here’s some other suggestions I found. BTW I always search using the term iMessage

A clean install frequently can fix problems on your Mac but it can’t fix iCloud.

I had this problem recently. Bizarrely, the fix for me was to turn Screen Time off and then on again. I can’t remember where I read this to credit it. It also happened for my sister last week and that also fixed it, so perhaps it is a recent update that has caused this.

As with all of these types of issues, you will find a large number of different potential solutions online and might need to try them all: I suspect we are seeing the downstream effect of one of any number of upstream problems.

I really enjoyed the lateral thinking with this suggestion. Sadly, it did not work, but I did spend 40 mins pondering other lateral steps that might fix the issue (e.g. privacy settings? Adblockers?)

Eventually I gave up and contacted Apple Support. Four hours, a lunch break and several staff later, they concluded they had exhausted their options and that most likely something had gone wrong when I deleted my drive and a setting hadn’t deleted properly that was “now in conflict”. Another two hours and a fresh install later, Messages is working once more.

It was a complete waste of my Friday, but I can’t fault Apple’s Support for methodically working through the issue and not giving up until they’d run out things to troubleshoot.

Just documenting here some of the steps that were meant to fix this, on the assumption that the next person who comes along will not have recently wiped their Mac [badly] and has a simple issue. Each action listed here was meant to fix the problem (so don’t do them all in one go, try them one at a time):

  1. Sign out of Messages on your Mac. Restart your Mac whilst signed out. Then sign back in.

  2. Check if another app that syncs by iCloud is syncing, e.g. Photos. If other apps are not syncing, the problem is iCloud, not specifically Messages.

  3. Ensure that the user has read&write permissions on the drive.

  4. Go to Library>Messages>Attachments and erase the files (this is meant to remove message attachments in case one of them is the problem that’s jamming the system)

  5. Go to Library>Messages and erase all .db files (this was scary but didn’t seem to do much at all)

  6. Call Apple Support, because at this point they started rummaging about in LaunchDaemons and other mysterious folders with a lego symbol and I don’t know what they were looking for.

Apple also made me restart in safe mode to check if Messages worked (it didn’t). And they made me create a test user account on the Mac. If Messages doesn’t work on the test user login, you know it’s an issue with the Mac or iCloud account. If the test user does work, you know it’s something to do with the main login (this is what happened with me).

I hope this helps someone some day, but mostly my suggestion is if the easy steps fail, call Apple. They have a whole manual for this stuff.

1 Like