Microsoft Office won't open files from recent files list

Hi all - a family member is experiencing an issue with MS Office apps not nopening files from the recent files list, although the files are there and can be opened. This happens randomly on some files and not others, on the same file sometimes and not other times and on both of the Mac accounts that are used on that machine.

We searched for remedies and the suggestions for removing plist files have no effect. Has anyone experienced this and if so, is there anything that works to resolve it?

Does the family member move the files to different folders?

2 Likes

Recent is tied to paths, to the file locations, not to the actual file. If a user moves the file it will read the saved path.

2 Likes

Find the file with Finder and “open with” the appropriate app. then after save should show up on Recent File list in that app. No?

1 Like

Have you tried to (1) clear the Recent Files list in an MS Office app (2) quit all apps (3) restart the Mac (4) both create a new MS Office document and open and edit an existing MS Office document in the app (5) and then check the Recent Files list for that app? Do the documents appear after a little while if not immediately? (I think I’ve noticed some unexplained delays in the updating of file system windows lately, which is why I ask.)

2 Likes

Thanks for the replies, here are the further details.

The file is not being moved between times.

One dialog (the excel version) says “Can’t open This workbook is either deleted or not currently accessible” and offers buttons OK and "Remove from Recent List.

The other version of the dialog says “Alert Excel can’t open the file because the file format or file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file.”

The file is still in the same place and can be opened from the folder in the usual way. However the user has a number of frequently used files and likes to use the recently used list.

The same thing happens with PowerPoint.

Google searches indicate some plists to delete but it doesn’t cure the issue. Various reboots etc have been tried, although I’m not sure the entire list of suggestions above have been tried yet. At this point I’m ready to nuke and pave MS Office if not the entire OS.

The machine is an iMac Pro currently running Monterey and was recently upgraded to 12.6 but the issue was happening before and is continuing after that update.

If you still want to fiddle with this, you could find where the number of files in the recent list is set and try changing the value. Set it to more or to none or to the maximum value. (I don’t have Word for Mac so can’t point you in the right direction.)

What version of Office/Excel/PowerPoint?

Have you tried creating a new User account and seeing if the problem persists ?

Two user accounts are in use on the machine regularly, it happens on both of them.

Have you tried completely rebuilding the Spotlight index on that machine?

1 Like