Military CAC Card reader on a Mac

I have a unique question and maybe I can get some help, please. I have a MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports) running Catalina 10.15.2 (19C57). It works great and is helping me get through life and school.

My situation is that I am Active Duty Military and often I need to check websites/emails that are behind encrypted walls. When MacOS upgraded to Catalina, this was supposed to help with us Mac users. I have followed all the prompts from Military cac.com https://militarycac.com/macnotes.htm which has always been the expert on this topic. I have this Cac card reader https://www.iogear.com/product/GSR205/ and my software is up-to-date. Initially everything was working great. Now not so much.

Initially, when I would go the sites, a drop-down would appear with my certificates and I would select the required one. I would enter my pin code and off I would go. (Safari Version 13.0.4 (15608.4.9.1.3)) . Now the pop-up window does not appear and that starts a cascade of error messages. It has never been successful with Chrome (Version 79.0.3945.88 (Official Build) (64-bit)).

I have tried the basics of clearing and rebooting but have unsuccessful. If you have any thoughts/suggestions/comments/references it would be greatly appreciated. Thanks and keep up the great work.

Joe

Yeah Catalina has been causing a lot of disruption to previously working setups, especially if they’re not very, very mainstream…if that’s any consolation.

You mention a pop-up that was appearing and now is not. Is it possible that Safari has been instructed to block that pop-up? Check Safari > Preferences > Websites > Pop-Up Windows (on the left). You want to see your site(s) listed with the drop-down set to Allow.

If that’s not the issue…

There’s a statement towards to the top of the page that is flashing “new”:

Mac users who choose to upgrade (or already have upgraded) to Mac OS Catalina (10.15.x) will need to uninstall all 3rd Party CAC enablers per https://militarycac.com/macuninstall.htm AND reenable the built in smart card ability (very bottom of macuninstall link above)

Did that uninstall/reenable of the smart card go smoothly with no hiccups or error messages? Even if it did, maybe go through their instructions from the beginning again, just to be sure it was followed exactly and everything “takes.”

It sounds like you had things working for a bit under Catalina so it is possible but something changed/broke (could be due to an update, config change, etc.) and this would “re-init” your setup. (Maybe repeat any other setup steps you need to take.)

Hope you get it back up and running!

3 Likes

Dude, from one military guy to another, I feel your pain. Sadly I can’t help since I don’t have my iMac upgraded to Catalina, but I wish you the best in trying to figure it out.

I’ll be honest, I’ve always battled CAC-accessible sites on the Mac…it seems like it works one time, then fails another. Or I log into OWA and I enter my PIN approximately 3,000 times as every piece of content loads. Very frustrating.

My “solution” is really not a solution…I bought a gaming Windows laptop last year and use that when I need to get to finicky CAC-enabled websites. (Not so) luckily, I have a work phone so the email problem is solved, just not the website ones without using my Windows laptop.

2 Likes

This issue was discussed a couple of times last year on the Icon Garden podcast, as one of the co-hosts, Jake Pugh, needs to use this type of reader. You might want to contact him through the show’s email link or on Twitter.

He has been trying to find a way to use it with an iPad Pro, and discussed his last findings in an episode last November.

Thanks. They had some good advise. Now I have another podcast in my line up.